CVE-2024-46955: Medium severity Artifex Ghostscript vulnerability
An issue was discovered in psi/zcolor.c in Artifex Ghostscript before 10.04.0. There is an out-of-bounds read when reading color in Indexed color space.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/ghostscriptto a version that resolves this vulnerability.Fixed in 10.0.0~dfsg-11+deb12u6 - Upgrade
Upgrade
debian/ghostscriptto a version that resolves this vulnerability.Fixed in 10.04.0~dfsg-1 - Upgrade
Upgrade
debian/ghostscriptto a version that resolves this vulnerability.Fixed in 10.0.0~dfsg-11+deb12u8Fixed in 10.05.1~dfsg-1+deb13u1Fixed in 10.05.1~dfsg-1+deb13u3Fixed in 10.08.0~dfsg-2 - Upgrade
Upgrade
alpine/ghostscriptto a version that resolves this vulnerability.Fixed in 10.04.0-r0 - Upgrade
Upgrade
Artifex Ghostscriptto a version that resolves this vulnerability.Fixed in 10.04.0
Event History
Frequently Asked Questions
What is the severity of CVE-2024-46955?
CVE-2024-46955 is classified as a high-severity vulnerability due to its potential for causing out-of-bounds read errors.
How do I fix CVE-2024-46955?
To fix CVE-2024-46955, update to Ghostscript version 10.04.0 or later, ensuring your installation is not below 9.53.3~dfsg-7+deb11u9.
Who is affected by CVE-2024-46955?
CVE-2024-46955 affects users of Ghostscript versions prior to 10.04.0, particularly those on Debian and SUSE Linux distributions.
What types of software are impacted by CVE-2024-46955?
CVE-2024-46955 impacts Artifex Ghostscript and related Debian and SUSE software packages.
Is a workaround available for CVE-2024-46955?
Currently, there is no official workaround for CVE-2024-46955, and updating to the patched version is the recommended mitigation.