CVE-2024-46956: High severity Artifex Ghostscript vulnerability
An issue was discovered in psi/zfile.c in Artifex Ghostscript before 10.04.0. Out-of-bounds data access in filenameforall can lead to arbitrary code execution.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/ghostscriptto a version that resolves this vulnerability.Fixed in 10.0.0~dfsg-11+deb12u6 - Upgrade
Upgrade
debian/ghostscriptto a version that resolves this vulnerability.Fixed in 10.04.0~dfsg-1 - Upgrade
Upgrade
debian/ghostscriptto a version that resolves this vulnerability.Fixed in 10.0.0~dfsg-11+deb12u8Fixed in 10.05.1~dfsg-1+deb13u1Fixed in 10.05.1~dfsg-1+deb13u3Fixed in 10.08.0~dfsg-2 - Upgrade
Upgrade
alpine/ghostscriptto a version that resolves this vulnerability.Fixed in 10.04.0-r0 - Upgrade
Upgrade
Artifex Ghostscriptto a version that resolves this vulnerability.Fixed in 10.04.0
Event History
Frequently Asked Questions
What is the severity of CVE-2024-46956?
CVE-2024-46956 has a high severity rating due to its potential for arbitrary code execution.
How do I fix CVE-2024-46956?
To fix CVE-2024-46956, update Ghostscript to version 10.04.0 or later.
Which versions of Ghostscript are affected by CVE-2024-46956?
Ghostscript versions prior to 10.04.0 are affected by CVE-2024-46956.
What platforms are impacted by CVE-2024-46956?
CVE-2024-46956 affects Debian and SUSE Linux distributions running vulnerable versions of Ghostscript.
Is there any workaround for CVE-2024-46956?
Disabling the filenameforall function in Ghostscript can serve as a temporary workaround for CVE-2024-46956.