CVE-2024-4768: Medium severity Mozilla Thunderbird vulnerability

Published May 14, 2024
·
Updated

A bug in popup notifications' interaction with WebAuthn made it easier for an attacker to trick a user into granting permissions.

Affected Software

18 affected componentsFixes available
Mozilla Thunderbird<115.11
115.11
Mozilla Firefox ESR<115.11
115.11
redhat/firefox<115.11
115.11
redhat/thunderbird<115.11
115.11
Mozilla Firefox<115.11.0
Mozilla Firefox<126.0
Mozilla Thunderbird<115.11.0
Debian Debian Linux=10.0
Mozilla Firefox<126
126
debian/firefox-esr<115.11.0esr-1~deb12u1
115.11.0esr-1~deb12u1
debian/firefox-esr<115.11.0esr-1
115.11.0esr-1
debian/firefox-esr<115.11.0esr-1
115.11.0esr-1
debian/thunderbird<1:115.11.0-1~deb12u1
1:115.11.0-1~deb12u1
debian/thunderbird<1:115.11.0-1
1:115.11.0-1
debian/thunderbird<1:115.11.0-1
1:115.11.0-1
debian/firefox
159.0.1-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 115.11
  2. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 115.11
  3. Upgrade

    Upgrade redhat/firefox to a version that resolves this vulnerability.

    Fixed in 115.11
  4. Upgrade

    Upgrade redhat/thunderbird to a version that resolves this vulnerability.

    Fixed in 115.11
  5. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 126
  6. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 115.11.0esr-1~deb12u1
  7. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 115.11.0esr-1
  8. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:115.11.0-1~deb12u1
  9. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:115.11.0-1
  10. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0.1-1
  11. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  12. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1

Event History

May 14, 2024
CVE Published
via Mozilla·12:00 AM
Data Sourced
via Mozilla·12:00 AM
DescriptionSeverityAffected Software
CVE Published
via MITRE·05:21 PM
Data Sourced
via MITRE·05:21 PM
DescriptionWeakness
Data Sourced
via NVD·06:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·06:15 PM
DescriptionSeverityAffected Software
Data Sourced
via Red Hat·06:37 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2024-4768?

CVE-2024-4768 has a high severity rating due to the potential for user permission spoofing by attackers.

2

How do I fix CVE-2024-4768?

To fix CVE-2024-4768, update Mozilla Firefox ESR to version 115.11 or later, Thunderbird to version 115.11 or later, and Firefox to version 126 or later.

3

What software is affected by CVE-2024-4768?

CVE-2024-4768 affects Mozilla Firefox ESR, Thunderbird, and standard Firefox versions prior to their respective updates.

4

Can CVE-2024-4768 be exploited remotely?

Yes, CVE-2024-4768 can potentially be exploited remotely if users are tricked into granting permissions.

5

Is there a known exploit for CVE-2024-4768?

As of now, there are no publicly disclosed exploits specifically targeting CVE-2024-4768, but the vulnerability poses a significant risk.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203