CVE-2024-5535: SSL_select_next_proto buffer overread

Published Jun 27, 2024
·
Updated

Issue summary: Calling the OpenSSL API function SSLselectnextproto with an empty supported client protocols buffer may cause a crash or memory contents to be sent to the peer.

Other sources

OpenSSL: CVE-2024-5535 SSLselectnextproto buffer overread

— Microsoft

We are republishing this OpenSSL CVE to document that the latest version Microsoft Defender for Endpoint has been updated to protect against this OpenSSL library vulnerability.

— Microsoft

Affected Software

51 affected componentsFixes available
Microsoft CBL Mariner 2.0 x64
Microsoft CBL Mariner 2.0 ARM
Microsoft Defender for Endpoint for Android
Microsoft Azure Linux 3.0 ARM
Microsoft Azure Linux 3.0 x64
Microsoft Defender for Endpoint for iOS
IBM Cognos Analytics<=11.2.0
IBM Cognos Analytics<=12.0
IBM Cognos Transformer<=12.0
IBM Cognos Transformer<=11.2.4
IBM Cognos Transformer<=12.1.0
IBM Cognos Analytics<=11.2.0
IBM Cognos Analytics<=12.1.0
IBM Cognos Analytics<=12.0
IBM Cognos Transformer<=11.2.4
IBM Cognos Transformer<=12.1.0
alpine/openssl<3.0.14-r0
3.0.14-r0
alpine/openssl<3.1.6-r0
3.1.6-r0
alpine/openssl<3.1.6-r0
3.1.6-r0
alpine/openssl<3.3.1-r1
3.3.1-r1
alpine/openssl<3.3.1-r1
3.3.1-r1
alpine/openssl<3.3.1-r1
3.3.1-r1
alpine/openssl<3.3.1-r1
3.3.1-r1
alpine/openssl<3.3.1-r1
3.3.1-r1
debian/openssl<3.0.15-1~deb12u1
3.0.15-1~deb12u1
debian/openssl<3.3.2-1
3.3.2-1
debian/openssl<3.3.2-1
3.3.2-1
debian/openssl
3.0.20-1~deb12u23.0.22-1~deb12u23.5.7-1~deb13u23.5.7-1~deb13u33.6.5-1
ubuntu/openssl<1.0.1f-1ubuntu2.27+esm16
1.0.1f-1ubuntu2.27+esm16
ubuntu/openssl<1.0.2g-1ubuntu4.20+esm18
1.0.2g-1ubuntu4.20+esm18
ubuntu/edk2*
ubuntu/openssl*
ubuntu/openssl*
ubuntu/openssl<1.1.1-1ubuntu2.1~18.04.23+esm10
1.1.1-1ubuntu2.1~18.04.23+esm10
ubuntu/openssl1.0<1.0.2n-1ubuntu5.13+esm6
1.0.2n-1ubuntu5.13+esm6
ubuntu/edk2*
ubuntu/openssl*
ubuntu/openssl*
ubuntu/openssl<1.1.1f-1ubuntu2.23
1.1.1f-1ubuntu2.23
ubuntu/edk2*
ubuntu/openssl*
ubuntu/edk2<2022.02-3ubuntu0.22.04.4
2022.02-3ubuntu0.22.04.4
ubuntu/openssl<3.0.2-0ubuntu1.17
3.0.2-0ubuntu1.17
ubuntu/nodejs*
ubuntu/openssl*
ubuntu/openssl-fips*
ubuntu/openssl<3.0.2-0ubuntu1.17+Fips1
3.0.2-0ubuntu1.17+Fips1
ubuntu/openssl-fips*
ubuntu/edk2<2024.02-2ubuntu0.6
2024.02-2ubuntu0.6
ubuntu/openssl<3.0.13-0ubuntu3.2
3.0.13-0ubuntu3.2
ubuntu/openssl-fips<3.0.13-0ubuntu3.6+Fips1
3.0.13-0ubuntu3.6+Fips1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade alpine/openssl to a version that resolves this vulnerability.

    Fixed in 3.0.14-r0
  2. Upgrade

    Upgrade alpine/openssl to a version that resolves this vulnerability.

    Fixed in 3.1.6-r0
  3. Upgrade

    Upgrade alpine/openssl to a version that resolves this vulnerability.

    Fixed in 3.3.1-r1
  4. Upgrade

    Upgrade debian/openssl to a version that resolves this vulnerability.

    Fixed in 3.0.15-1~deb12u1
  5. Upgrade

    Upgrade debian/openssl to a version that resolves this vulnerability.

    Fixed in 3.3.2-1
  6. Upgrade

    Upgrade debian/openssl to a version that resolves this vulnerability.

    Fixed in 3.0.20-1~deb12u2Fixed in 3.0.22-1~deb12u2Fixed in 3.5.7-1~deb13u2Fixed in 3.5.7-1~deb13u3Fixed in 3.6.5-1
  7. Upgrade

    Upgrade ubuntu/openssl to a version that resolves this vulnerability.

    Fixed in 1.0.1f-1ubuntu2.27+esm16
  8. Upgrade

    Upgrade ubuntu/openssl to a version that resolves this vulnerability.

    Fixed in 1.0.2g-1ubuntu4.20+esm18
  9. Upgrade

    Upgrade ubuntu/openssl to a version that resolves this vulnerability.

    Fixed in 1.1.1-1ubuntu2.1~18.04.23+esm10
  10. Upgrade

    Upgrade ubuntu/openssl1.0 to a version that resolves this vulnerability.

    Fixed in 1.0.2n-1ubuntu5.13+esm6
  11. Upgrade

    Upgrade ubuntu/openssl to a version that resolves this vulnerability.

    Fixed in 1.1.1f-1ubuntu2.23
  12. Upgrade

    Upgrade ubuntu/edk2 to a version that resolves this vulnerability.

    Fixed in 2022.02-3ubuntu0.22.04.4
  13. Upgrade

    Upgrade ubuntu/openssl to a version that resolves this vulnerability.

    Fixed in 3.0.2-0ubuntu1.17
  14. Upgrade

    Upgrade ubuntu/openssl to a version that resolves this vulnerability.

    Fixed in 3.0.2-0ubuntu1.17+Fips1
  15. Upgrade

    Upgrade ubuntu/edk2 to a version that resolves this vulnerability.

    Fixed in 2024.02-2ubuntu0.6
  16. Upgrade

    Upgrade ubuntu/openssl to a version that resolves this vulnerability.

    Fixed in 3.0.13-0ubuntu3.2
  17. Upgrade

    Upgrade ubuntu/openssl-fips to a version that resolves this vulnerability.

    Fixed in 3.0.13-0ubuntu3.6+Fips1

Event History

Jun 27, 2024
CVE Published
via MITRE·10:30 AM
Data Sourced
via MITRE·10:30 AM
DescriptionWeakness
Data Sourced
via OSV·11:15 AM
DescriptionSeverityAffected Software
Data Sourced
via NVD·11:15 AM
DescriptionSeverityWeakness
Data Sourced
via Red Hat·12:29 PM
DescriptionSeverityAffected Software
Nov 12, 2024
Data Sourced
via Microsoft·08:00 AM
DescriptionSeverityWeakness
Mar 15, 2025
Exploit Published
via GitHub·05:00 PM
May 14, 2026
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-5535?

CVE-2024-5535 is classified as a moderate severity vulnerability due to its potential impact on applications using OpenSSL.

2

How do I fix CVE-2024-5535?

To fix CVE-2024-5535, update your OpenSSL to version 3.3.2-1 or later if you are using an affected distribution.

3

What software is affected by CVE-2024-5535?

CVE-2024-5535 affects various versions of OpenSSL as implemented in products like Microsoft Azure Linux and Defender for Endpoint.

4

Does Microsoft Defender protect against CVE-2024-5535?

Yes, the latest version of Microsoft Defender for Endpoint has been updated to protect against CVE-2024-5535.

5

What is the OpenSSL API function related to CVE-2024-5535?

CVE-2024-5535 is related to the OpenSSL API function SSL_select_next_proto when called with an empty supported client list.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203