CVE-2024-7091: Exposure of Sensitive Information to an Unauthorized Actor in GitLab
An issue was discovered in GitLab CE/EE affecting all versions starting from 15.6 prior to 17.0.5, starting from 17.1 prior to 17.1.3, and starting from 17.2 prior to 17.2.1 where it was possible to disclose limited information of an exported group or project to another user.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.0.5 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.1.3 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.2.1
Event History
Frequently Asked Questions
What is the severity of CVE-2024-7091?
CVE-2024-7091 is classified as a medium severity vulnerability due to its potential to disclose limited information to unauthorized users.
How do I fix CVE-2024-7091?
To fix CVE-2024-7091, upgrade your GitLab installation to version 17.0.5 or later, version 17.1.3 or later, or version 17.2.1 or later.
What versions of GitLab are affected by CVE-2024-7091?
CVE-2024-7091 affects GitLab CE/EE versions from 15.6 up to but not including 17.0.5, from 17.1 up to but not including 17.1.3, and from 17.2 up to but not including 17.2.1.
What type of information can be disclosed due to CVE-2024-7091?
CVE-2024-7091 may allow unauthorized users to access limited information about an exported group or project.
Is there a workaround for CVE-2024-7091?
Currently, there is no known workaround for CVE-2024-7091; upgrading to the patched versions is the recommended action.