CVE-2024-7554: Exposure of Sensitive Information to an Unauthorized Actor in GitLab
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.9 before 17.0.6, all versions starting from 17.1 before 17.1.4, all versions starting from 17.2 before 17.2.2. Under certain conditions, access tokens may have been logged when an API request was made in a specific manner.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.2.2 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.1.4 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.0.6
Event History
Frequently Asked Questions
What is the severity of CVE-2024-7554?
CVE-2024-7554 is considered a high severity vulnerability affecting GitLab instances.
How do I fix CVE-2024-7554?
To fix CVE-2024-7554, update your GitLab installation to version 17.0.6 or newer, or 17.1.4 or newer, as applicable.
What versions are affected by CVE-2024-7554?
CVE-2024-7554 affects GitLab CE/EE versions from 13.9 up to 17.0.6, and 17.1 from 17.1.0 up to 17.1.4.
What does CVE-2024-7554 vulnerability entail?
CVE-2024-7554 involves the potential for access tokens to be logged when an API request is made under certain conditions.
Is CVE-2024-7554 a critical vulnerability?
While not classified as critical, CVE-2024-7554 poses significant risks due to the exposure of access tokens.