CVE-2024-8638: Type Confusion in V8
Chromium: CVE-2024-8638 Type Confusion in V8
Other sources
This CVE was assigned by Chrome. Microsoft Edge (Chromium-based) ingests Chromium, which addresses this vulnerability. Please see Google Chrome Releases for more information.
— Microsoft
Type Confusion in V8 in Google Chrome prior to 128.0.6613.137 allowed a remote attacker to potentially exploit object corruption via a crafted HTML page. (Chromium security severity: High)
— MITRE
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 128.0.6613.137 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.73-1 - Upgrade
Upgrade
Google Chrometo a version that resolves this vulnerability.Fixed in 128.0.6613.137
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2024-8638?
CVE-2024-8638 is classified as a type confusion vulnerability in Chromium, which could potentially allow for arbitrary code execution.
How do I fix CVE-2024-8638?
To fix CVE-2024-8638, users should update Google Chrome to version 128.0.6613.137 or higher and Microsoft Edge to version 128.0.2739.79 or higher.
Which versions of Chrome and Edge are affected by CVE-2024-8638?
CVE-2024-8638 affects Google Chrome versions below 128.0.6613.137 and Microsoft Edge (Chromium-based) versions below 128.0.2739.79.
Is CVE-2024-8638 specific to any operating system?
CVE-2024-8638 is not specific to any operating system but affects Chromium-based browsers running on supported platforms.
Can CVE-2024-8638 be exploited remotely?
Yes, CVE-2024-8638 can potentially be exploited remotely, giving attackers the ability to execute arbitrary code.