CVE-2025-0238: Use-after-free when breaking lines in text

Published Jan 7, 2025
·
Updated

Assuming a controlled failed memory allocation, an attacker could have caused a use-after-free, leading to a potentially exploitable crash. This vulnerability was fixed in Firefox 134, Firefox ESR 128.6, Firefox ESR 115.19, Thunderbird 134, and Thunderbird 128.6.

Other sources

Assuming a controlled failed memory allocation, an attacker could have caused a use-after-free, leading to a potentially exploitable crash. This vulnerability affects Firefox < 134, Firefox ESR < 128.6, and Firefox ESR < 115.19.

— Red Hat

Assuming a controlled failed memory allocation, an attacker could have caused a use-after-free, leading to a potentially exploitable crash. This vulnerability affects Firefox < 134, Firefox ESR < 128.6, Firefox ESR < 115.19, Thunderbird < 134, and Thunderbird < 128.6.

— OSV

Affected Software

24 affected componentsFixes available
Mozilla Thunderbird<134
134
Mozilla Firefox ESR<115.19
115.19
Mozilla Firefox ESR<128.6
128.6
Mozilla Firefox<115.19.0
Mozilla Firefox<134.0
Mozilla Firefox>=116.0<128.6.0
Mozilla Thunderbird<128.6
Mozilla Thunderbird>=129.0<134.0
ubuntu/mozjs52*
ubuntu/mozjs38*
ubuntu/firefox<134.0+build1-0ubuntu0.20.04.1
134.0+build1-0ubuntu0.20.04.1
ubuntu/mozjs68*
ubuntu/mozjs52*
ubuntu/mozjs102*
ubuntu/mozjs78*
ubuntu/mozjs91*
ubuntu/thunderbird<1:128.12.0+build1-0ubuntu0.22.04.1
1:128.12.0+build1-0ubuntu0.22.04.1
ubuntu/mozjs102*
ubuntu/mozjs115*
Mozilla Firefox<134
134
Mozilla Thunderbird<128.6
128.6
debian/firefox
159.0.1-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 134
  2. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 115.19
  3. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 128.6
  4. Upgrade

    Upgrade ubuntu/firefox to a version that resolves this vulnerability.

    Fixed in 134.0+build1-0ubuntu0.20.04.1
  5. Upgrade

    Upgrade ubuntu/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:128.12.0+build1-0ubuntu0.22.04.1
  6. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 134
  7. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 128.6
  8. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0.1-1
  9. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  10. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
  11. Upgrade

    Upgrade Firefox to a version that resolves this vulnerability.

    Fixed in 134
  12. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 128.6

Event History

Jan 7, 2025
CVE Published
via Mozilla·12:00 AM
Data Sourced
via Mozilla·12:00 AM
DescriptionSeverityAffected Software
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·04:07 PM
Data Sourced
via MITRE·04:07 PM
Description
Data Sourced
via OSV·04:15 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·04:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Red Hat·05:01 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2025-0238?

CVE-2025-0238 is classified as a potentially exploitable vulnerability due to its use-after-free condition.

2

How do I fix CVE-2025-0238?

To remediate CVE-2025-0238, update affected Mozilla products to versions 134.0 or 128.6 and ensure all security patches are applied.

3

Which software is affected by CVE-2025-0238?

CVE-2025-0238 affects Mozilla Firefox ESR, Mozilla Firefox, and Mozilla Thunderbird versions prior to the specified remedial versions.

4

What are the potential impacts of CVE-2025-0238?

Exploitation of CVE-2025-0238 may result in application crashes and could allow an attacker to execute arbitrary code.

5

Can CVE-2025-0238 be exploited remotely?

Yes, CVE-2025-0238 can potentially be exploited remotely through controlled failed memory allocations.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203