CVE-2025-0605: Weak Authentication in GitLab

Published May 21, 2025
·
Updated

An issue has been discovered in GitLab CE/EE affecting all versions from 16.8 before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. Group access controls could allow certain users to bypass two-factor authentication requirements.

Affected Software

8 affected componentsFixes available
GitLab GitLab CE/EE>16.8, <17.10.7, >17.11, <17.11.3, >18.0, <18.0.1
GitLab GitLab>=16.8.0<17.10.7
GitLab GitLab>=16.8.0<17.10.7
GitLab GitLab>=17.11.0<17.11.3
GitLab GitLab>=17.11.0<17.11.3
GitLab GitLab=18.0.0
GitLab GitLab=18.0.0
GitLab GitLab>=16.8<17.10.7, >=17.11<17.11.3, >=18.0<18.0.1
17.10.717.11.318.0.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 17.10.7Fixed in 17.11.3Fixed in 18.0.1
  2. Upgrade

    Upgrade GitLab CE/EE to a version that resolves this vulnerability.

    Fixed in 17.10.7
  3. Upgrade

    Upgrade GitLab CE/EE to a version that resolves this vulnerability.

    Fixed in 17.11.3
  4. Upgrade

    Upgrade GitLab CE/EE to a version that resolves this vulnerability.

    Fixed in 18.0.1

Event History

May 22, 2025
CVE Published
via MITRE·02:31 PM
Data Sourced
via MITRE·02:31 PM
RemedyDescriptionSeverityWeakness
Data Sourced
via OSV·02:31 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·03:16 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-0605?

CVE-2025-0605 is considered a high-severity vulnerability due to its potential to allow unauthorized bypass of two-factor authentication.

2

How do I fix CVE-2025-0605?

To fix CVE-2025-0605, upgrade GitLab CE/EE to version 17.10.7, 17.11.3, or 18.0.1 or later.

3

What versions are affected by CVE-2025-0605?

CVE-2025-0605 affects all GitLab CE/EE versions from 16.8 to below 17.10.7, from 17.11 to below 17.11.3, and from 18.0 to below 18.0.1.

4

Who is impacted by CVE-2025-0605?

Users with group access in GitLab CE/EE could be impacted by CVE-2025-0605 if they are able to bypass two-factor authentication.

5

Is there a workaround for CVE-2025-0605?

No official workaround is recommended for CVE-2025-0605; upgrading to the patched versions is necessary to mitigate the risk.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203