CVE-2025-0993: Allocation of Resources Without Limits or Throttling in GitLab
An issue has been discovered in GitLab CE/EE affecting all versions before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. This could allow an authenticated attacker to cause a denial of service condition by exhausting server resources.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 17.11.3Fixed in 18.0.1 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.10.7 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.11.3 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 18.0.1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2025-0993?
CVE-2025-0993 has a high severity rating due to its potential to cause denial of service conditions.
How do I fix CVE-2025-0993?
To fix CVE-2025-0993, upgrade to GitLab versions 17.10.7, 17.11.3, or 18.0.1 or later.
Who is affected by CVE-2025-0993?
CVE-2025-0993 affects all versions of GitLab CE and EE prior to the specified fixed versions.
What type of attack is associated with CVE-2025-0993?
CVE-2025-0993 is associated with a resource exhaustion attack leading to a denial of service.
Is CVE-2025-0993 an authenticated vulnerability?
Yes, CVE-2025-0993 requires authentication to exploit the denial of service condition.