CVE-2025-43228: Input Validation

Published Jul 29, 2025
·
Updated

Accessibility. A logic issue was addressed with improved checks.

Other sources

Accessibility. The issue was addressed by adding additional logic.

— Apple

afclip. The issue was addressed with improved memory handling.

— Apple

CFNetwork. A denial-of-service issue was addressed with improved input validation.

— Apple

CoreAudio. The issue was addressed with improved memory handling.

— Apple

CoreMedia Playback. The issue was addressed with additional permissions checks.

— Apple

Credit

Sergei Glazunov(Google Project Zero), Ivan Fratric(Google Project Zero), Andreas Jaegersberger & Ro Achterberg(Nosebeard Labs), Martin Bajanik(Fingerprint), Ammar Askar, Jaydev Ahire, Gilad Moav, Yehuda Afek, Anat Bremler-Barr, Amit Klein, Yuhao Hu, Yan Kang, Chenggang Wu, Xiaojie Wei, Syarif Muhammad Sajjad, shandikri(Trend Micro Zero Day Initiative), Google V8 Security Team, Nan Wang@@eternalsakura13, Ziling Chen, HexRabbit@@h3xr4bb1t(DEVCORE Research Team), Ignacio Sanmillan@@ulexec, Clément Lecigne(Google's Threat Analysis Group), Vlad Stolyarov(Google's Threat Analysis Group), Wong Wee Xiang, Himanshu Bharti@@Xpl0itme, Hossein Lotfi@@hosselot(Trend Micro Zero Day Initiative), Google's Threat Analysis Group, Chi Yuan Chang(ZUSO ART), taikosoup, Gary Kwong(Trend Micro Zero Day Initiative), CVE-2025-43226, Christian Kohlschütter, Brian Carpenter, Michael DePlante@@izobashi(Trend Micro Zero Day Initiative), CVE-2025-6965

Affected Software

24 affected componentsFixes available
Apple iOS<18.6
18.6
Apple iPadOS<18.6
18.6
Apple Safari<18.6
18.6
Apple Safari<18.6
Apple iPadOS<18.6
Apple iPhone OS<18.6
ubuntu/qtwebkit-opensource-src*
ubuntu/webkit2gtk*
ubuntu/qtwebkit-source*
ubuntu/webkitgtk*
ubuntu/webkit2gtk*
ubuntu/qtwebkit-opensource-src*
ubuntu/qtwebkit-source*
ubuntu/webkitgtk*
ubuntu/webkit2gtk*
ubuntu/qtwebkit-opensource-src*
ubuntu/wpewebkit*
ubuntu/qtwebkit-opensource-src*
ubuntu/webkit2gtk<2.48.5-0ubuntu0.22.04.1
2.48.5-0ubuntu0.22.04.1
ubuntu/wpewebkit*
ubuntu/qtwebkit-opensource-src*
ubuntu/webkit2gtk<2.48.5-0ubuntu0.24.04.1
2.48.5-0ubuntu0.24.04.1
debian/webkit2gtk
2.50.6-1~deb12u22.50.6-1~deb12u12.52.6-1~deb13u12.54.0-1~deb13u32.52.6-12.54.2-2
debian/wpewebkit<=2.38.6-1, <=2.48.3-1
2.54.2-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 18.6
  2. Upgrade

    Upgrade ubuntu/webkit2gtk to a version that resolves this vulnerability.

    Fixed in 2.48.5-0ubuntu0.22.04.1
  3. Upgrade

    Upgrade ubuntu/webkit2gtk to a version that resolves this vulnerability.

    Fixed in 2.48.5-0ubuntu0.24.04.1
  4. Upgrade

    Upgrade debian/webkit2gtk to a version that resolves this vulnerability.

    Fixed in 2.50.6-1~deb12u2Fixed in 2.50.6-1~deb12u1Fixed in 2.52.6-1~deb13u1Fixed in 2.54.0-1~deb13u3Fixed in 2.52.6-1Fixed in 2.54.2-2
  5. Upgrade

    Upgrade debian/wpewebkit to a version that resolves this vulnerability.

    Fixed in 2.54.2-1
  6. Upgrade

    Upgrade Safari, iOS, and iPadOS to a version that resolves this vulnerability.

    Fixed in 18.6
  7. Compensating control

    Do not load remote images.

Event History

Jul 29, 2025
Data Sourced
via Apple·12:00 AM
DescriptionWeaknessAffected Software
CVE Published
via MITRE·11:35 PM
Data Sourced
via MITRE·11:35 PM
DescriptionWeakness
Jul 30, 2025
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·12:15 AM
DescriptionSeverityAffected Software
Data Sourced
via NVD·12:15 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2025-43228?

The severity of CVE-2025-43228 has been determined to be significant due to multiple issues that could lead to denial-of-service conditions.

2

How do I fix CVE-2025-43228?

To fix CVE-2025-43228, update your Apple iOS, iPadOS, or Safari to version 18.6 or later.

3

What are the affected products for CVE-2025-43228?

CVE-2025-43228 affects Apple iOS, iPadOS, and Safari versions up to 18.6.

4

What types of issues does CVE-2025-43228 address?

CVE-2025-43228 addresses logic issues, improved checks, memory handling improvements, and denial-of-service vulnerabilities.

5

Is CVE-2025-43228 related to accessibility?

Yes, CVE-2025-43228 includes improvements made to address accessibility-related issues.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203