CVE-2025-4918: Out-of-bounds access when resolving Promise objects

Published May 17, 2025
·
Updated

An attacker was able to perform an out-of-bounds read or write on a JavaScript Promise object. This vulnerability was fixed in Firefox 138.0.4, Firefox ESR 128.10.1, Firefox ESR 115.23.1, Thunderbird 128.10.2, and Thunderbird 138.0.2.

Other sources

An attacker was able to perform an out-of-bounds read or write on a JavaScript Promise object. This vulnerability affects Firefox ESR < 115.23.1.

— Red Hat

An attacker was able to perform an out-of-bounds read or write on a JavaScript Promise object.

— Mozilla

Affected Software

23 affected componentsFixes available
Mozilla Thunderbird<138.0.2
138.0.2
Mozilla Firefox<115.23.1
Mozilla Firefox<138.0.4
Mozilla Firefox>=116.0<128.10.1
Mozilla Thunderbird<128.10.2
Mozilla Thunderbird>=138.0<138.0.2
ubuntu/mozjs52*
ubuntu/mozjs38*
ubuntu/mozjs68*
ubuntu/mozjs52*
ubuntu/mozjs102*
ubuntu/mozjs78*
ubuntu/mozjs91*
ubuntu/thunderbird<1:128.12.0+build1-0ubuntu0.22.04.1
1:128.12.0+build1-0ubuntu0.22.04.1
ubuntu/mozjs102*
ubuntu/mozjs115*
Mozilla Firefox ESR<115.23.1
115.23.1
Mozilla Thunderbird<128.10.2
128.10.2
Mozilla Firefox<138.0.4
138.0.4
Mozilla Firefox ESR<128.10.1
128.10.1
debian/firefox
159.0.1-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 138.0.2
  2. Upgrade

    Upgrade ubuntu/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:128.12.0+build1-0ubuntu0.22.04.1
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 115.23.1
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 128.10.2
  5. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 138.0.4
  6. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 128.10.1
  7. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0.1-1
  8. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  9. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
  10. Upgrade

    Upgrade Firefox to a version that resolves this vulnerability.

    Fixed in 138.0.4
  11. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 128.10.1
  12. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 115.23.1
  13. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 128.10.2

Event History

May 17, 2025
CVE Published
via Mozilla·12:00 AM
Data Sourced
via Mozilla·12:00 AM
DescriptionSeverityAffected Software
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·09:07 PM
Data Sourced
via MITRE·09:07 PM
Description
Data Sourced
via Red Hat·10:01 PM
DescriptionSeverityAffected Software
Data Sourced
via OSV·10:15 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·10:15 PM
DescriptionSeverityWeaknessAffected Software
May 19, 2025
News Published
via BleepingComputer·02:03 PM
News Published
via BleepingComputer·02:10 PM

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-4918?

CVE-2025-4918 is classified as a high severity vulnerability due to its potential to allow attackers to read or write out-of-bounds memory.

2

How do I fix CVE-2025-4918?

To mitigate CVE-2025-4918, update your Mozilla Firefox ESR to version 115.23.2 or later.

3

What types of attacks can exploit CVE-2025-4918?

CVE-2025-4918 can be exploited through specifically crafted JavaScript that targets Promise objects, leading to out-of-bounds memory access.

4

Who is affected by CVE-2025-4918?

CVE-2025-4918 affects users of Mozilla Firefox ESR versions up to and including 115.23.1.

5

Is CVE-2025-4918 being actively exploited in the wild?

There are currently no confirmed reports of CVE-2025-4918 being actively exploited in the wild.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203