CVE-2025-5064: Inappropriate implementation in Background Fetch API
Chromium: CVE-2025-5064 Inappropriate implementation in Background Fetch API
Other sources
Inappropriate implementation in Background Fetch API in Google Chrome prior to 137.0.7151.55 allowed a remote attacker to leak cross-origin data via a crafted HTML page. (Chromium security severity: Medium)
— NVD
This CVE was assigned by Chrome. Microsoft Edge (Chromium-based) ingests Chromium, which addresses this vulnerability. Please see Google Chrome Releases for more information.
— Microsoft
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrometo a version that resolves this vulnerability.Fixed in 137.0.7151.55 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1 - Upgrade
Upgrade
alpine/qt6-qtwebengineto a version that resolves this vulnerability.Fixed in 6.8.3-r1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2025-5064?
CVE-2025-5064 has a medium severity rating as it allows a remote attacker to leak cross-origin data.
How do I fix CVE-2025-5064?
To fix CVE-2025-5064, you should update Google Chrome to version 137.0.7151.55 or later.
What does CVE-2025-5064 affect?
CVE-2025-5064 affects Google Chrome versions prior to 137.0.7151.55.
Who is affected by CVE-2025-5064?
Users of Google Chrome versions earlier than 137.0.7151.55 are potentially vulnerable to CVE-2025-5064.
What kind of attack does CVE-2025-5064 allow?
CVE-2025-5064 allows a remote attacker to leak cross-origin data through a crafted HTML page.