CVE-2025-5065: Inappropriate implementation in FileSystemAccess API
Chromium: CVE-2025-5065 Inappropriate implementation in FileSystemAccess API
Other sources
Inappropriate implementation in FileSystemAccess API in Google Chrome prior to 137.0.7151.55 allowed a remote attacker to perform UI spoofing via a crafted HTML page. (Chromium security severity: Medium)
— NVD
This CVE was assigned by Chrome. Microsoft Edge (Chromium-based) ingests Chromium, which addresses this vulnerability. Please see Google Chrome Releases for more information.
— Microsoft
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrometo a version that resolves this vulnerability.Fixed in 137.0.7151.55 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1 - Upgrade
Upgrade
alpine/qt6-qtwebengineto a version that resolves this vulnerability.Fixed in 6.8.3-r1 - Upgrade
Upgrade
Chromiumto a version that resolves this vulnerability.Fixed in 137.0.7151.55
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2025-5065?
The severity of CVE-2025-5065 is classified as Medium by Chromium security.
How do I fix CVE-2025-5065?
To fix CVE-2025-5065, update Google Chrome to version 137.0.7151.55 or later.
Which versions of Google Chrome are affected by CVE-2025-5065?
CVE-2025-5065 affects all versions of Google Chrome prior to 137.0.7151.55.
What vulnerability does CVE-2025-5065 address?
CVE-2025-5065 addresses an inappropriate implementation in the FileSystemAccess API allowing UI spoofing.
Can CVE-2025-5065 be exploited remotely?
Yes, CVE-2025-5065 can be exploited by a remote attacker through a crafted HTML page.