CVE-2025-9179: Sandbox escape due to invalid pointer in the Audio/Video: GMP component

Published Aug 19, 2025
·
Updated

An attacker was able to perform memory corruption in the GMP process which processes encrypted media. This process is also heavily sandboxed, but represents slightly different privileges from the content process. This vulnerability was fixed in Firefox 142, Firefox ESR 115.27, Firefox ESR 128.14, Firefox ESR 140.2, Thunderbird 142, Thunderbird 128.14, and Thunderbird 140.2.

Other sources

An attacker was able to perform memory corruption in the GMP process which processes encrypted media. This process is also heavily sandboxed, but represents slightly different privileges from the content process. This vulnerability affects Firefox < 142, Firefox ESR < 115.27, Firefox ESR < 128.14, Firefox ESR < 140.2, Thunderbird < 142, Thunderbird < 128.14, and Thunderbird < 140.2.

— Red Hat

Affected Software

30 affected componentsFixes available
Mozilla Firefox<142
Mozilla Firefox ESR<115.27, <128.14, <140.2
Mozilla Thunderbird<142, <128.14, <140.2
Mozilla Thunderbird<142
142
Mozilla Firefox ESR<115.27
115.27
Mozilla Thunderbird<140.2
140.2
Mozilla Firefox ESR<140.2
140.2
Mozilla Firefox<115.27.0
Mozilla Firefox<142.0
Mozilla Firefox>=128.0<128.14.0
Mozilla Firefox>=140.0<140.2.0
Mozilla Thunderbird<128.14.0
Mozilla Thunderbird<142.0
Mozilla Thunderbird>=140.0<140.2.0
ubuntu/mozjs52*
ubuntu/mozjs38*
ubuntu/mozjs68*
ubuntu/mozjs52*
ubuntu/mozjs102*
ubuntu/mozjs78*
ubuntu/mozjs91*
ubuntu/thunderbird<1:140.7.1+build1-0ubuntu0.22.04.1
1:140.7.1+build1-0ubuntu0.22.04.1
ubuntu/mozjs102*
ubuntu/mozjs115*
Mozilla Firefox<142
142
Mozilla Firefox ESR<128.14
128.14
Mozilla Thunderbird<128.14
128.14
debian/firefox
159.0-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 142
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 115.27
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 140.2
  4. Upgrade

    Upgrade ubuntu/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.7.1+build1-0ubuntu0.22.04.1
  5. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 128.14
  6. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0-1
  7. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  8. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u1Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
  9. Upgrade

    Upgrade Firefox to a version that resolves this vulnerability.

    Fixed in 142
  10. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 115.27
  11. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 128.14
  12. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 140.2
  13. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 142
  14. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 128.14
  15. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 140.2

Event History

Aug 19, 2025
CVE Published
via Mozilla·12:00 AM
Data Sourced
via Mozilla·12:00 AM
DescriptionSeverityAffected Software
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·08:33 PM
Data Sourced
via MITRE·08:33 PM
Description
Data Sourced
via Red Hat·09:01 PM
DescriptionSeverityAffected Software
Data Sourced
via OSV·09:15 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·09:15 PM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2025-9179?

CVE-2025-9179 has been rated as a critical vulnerability due to its potential for memory corruption in the GMP process.

2

How do I fix CVE-2025-9179?

To fix CVE-2025-9179, update Firefox to version 142 or later, and Firefox ESR to 115.27, 128.14, or higher.

3

Which versions are affected by CVE-2025-9179?

CVE-2025-9179 affects Firefox versions prior to 142 and Firefox ESR versions prior to 115.27 and 128.14.

4

What products are impacted by CVE-2025-9179?

The impacted products include Mozilla Firefox, Firefox ESR, and Mozilla Thunderbird versions below the specified thresholds.

5

Is CVE-2025-9179 a local or remote vulnerability?

CVE-2025-9179 is categorized as a remote vulnerability, potentially exploited over the network.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203