CVE-2026-21277: InDesign Desktop | Heap-based Buffer Overflow (CWE-122)
InDesign Desktop versions 21.0, 19.5.5 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected Software
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2026-21277?
CVE-2026-21277 is classified as a critical severity vulnerability due to its potential for arbitrary code execution.
How do I fix CVE-2026-21277?
To mitigate CVE-2026-21277, ensure that you update Adobe InDesign Desktop to version 21.1 or later.
What versions of Adobe InDesign Desktop are affected by CVE-2026-21277?
Adobe InDesign Desktop versions 21.0, 19.5.5, and earlier are affected by CVE-2026-21277.
What type of vulnerability is CVE-2026-21277?
CVE-2026-21277 is a heap-based buffer overflow vulnerability.
Does CVE-2026-21277 require user interaction for exploitation?
Yes, exploitation of CVE-2026-21277 requires user interaction.