CVE-2026-27272: Illustrator | Out-of-bounds Write (CWE-787)
Illustrator versions 29.8.4, 30.1 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected Software
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2026-27272?
CVE-2026-27272 is a critical severity vulnerability that can lead to arbitrary code execution.
How do I fix CVE-2026-27272?
To resolve CVE-2026-27272, users should upgrade Adobe Illustrator to version 30.2 or later.
Which versions of Illustrator are affected by CVE-2026-27272?
Adobe Illustrator versions 29.8.4 and 30.1 and earlier are affected by CVE-2026-27272.
What type of vulnerability is CVE-2026-27272?
CVE-2026-27272 is categorized as an out-of-bounds write vulnerability.
What are the risks of CVE-2026-27272 exploitation?
Exploitation of CVE-2026-27272 can lead to arbitrary code execution in the context of the current user.