CVE-2026-97229: Integer Overflow or Wraparound in GitLab

Published Oct 13, 2026
·
Updated

GitLab Community Edition and Enterprise Edition contain a integer overflow or wraparound vulnerability that could allow an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.

Other sources

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.

— NVD

Integer Overflow or Wraparound in GitLab

— Microsoft

Affected Software

28 affected componentsFixes available
GitLab GitLab CE/EE>=19.2<19.2.8, >=19.3<19.3.5, >=19.4<19.4.2
All of the following
azurelinux/ruby<3.3.13-0
3.3.13-0
Microsoft Azure Linux=3.0
All of the following
azurelinux/ruby<0:3.4.12-38.azl4
0:3.4.12-38.azl4
Microsoft Azure Linux=4.0
GitLab Community Edition and Enterprise Edition
debian/ruby3.1<=3.1.2-7+deb12u1
debian/ruby3.3<=3.3.8-2, <=3.3.8-2.2
bitnami/gitlab>=19.2.0<19.2.8
19.2.8
bitnami/gitlab>=19.3.0<19.3.5
19.3.5
bitnami/gitlab>=19.4.0<19.4.2
19.4.2
GitLab GitLab>=19.2.0<19.2.8
GitLab GitLab>=19.2.0<19.2.8
GitLab GitLab>=19.3.0<19.3.5
GitLab GitLab>=19.3.0<19.3.5
GitLab GitLab>=19.4.0<19.4.2
GitLab GitLab>=19.4.0<19.4.2
ubuntu/gitlab*
debian/ruby3.1*
debian/ruby3.3*
debian/ruby3.3*
ruby-lang Ruby>=3.3.0<3.3.13
ruby-lang Ruby>=3.4.0<3.4.12
ruby-lang Ruby>=4.0.0<4.0.8
alpine/ruby>=3.3.0<3.3.13-r0
3.3.13-r0
alpine/ruby>=3.3.0<3.4.12-r0
3.4.12-r0
alpine/ruby>=3.3.0<3.4.12-r0
3.4.12-r0
alpine/ruby>=3.3.0<3.4.12-r0
3.4.12-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade azurelinux/ruby to a version that resolves this vulnerability.

    Fixed in 3.3.13-0
  2. Upgrade

    Upgrade azurelinux/ruby to a version that resolves this vulnerability.

    Fixed in 0:3.4.12-38.azl4
  3. Upgrade

    Upgrade bitnami/gitlab to a version that resolves this vulnerability.

    Fixed in 19.2.8
  4. Upgrade

    Upgrade bitnami/gitlab to a version that resolves this vulnerability.

    Fixed in 19.3.5
  5. Upgrade

    Upgrade bitnami/gitlab to a version that resolves this vulnerability.

    Fixed in 19.4.2
  6. Upgrade

    Upgrade alpine/ruby to a version that resolves this vulnerability.

    Fixed in 3.3.13-r0
  7. Upgrade

    Upgrade alpine/ruby to a version that resolves this vulnerability.

    Fixed in 3.4.12-r0
  8. Upgrade

    Upgrade GitLab Community Edition and Enterprise Edition to a version that resolves this vulnerability.

    Fixed in 19.2.8
  9. Upgrade

    Upgrade GitLab Community Edition and Enterprise Edition to a version that resolves this vulnerability.

    Fixed in 19.3.5
  10. Upgrade

    Upgrade GitLab Community Edition and Enterprise Edition to a version that resolves this vulnerability.

    Fixed in 19.4.2

Event History

Oct 13, 2026
CVE Published
via MITRE·01:05 AM
Data Sourced
via MITRE·01:05 AM
RemedyDescriptionSeverityWeakness
Data Sourced
via OSV·01:05 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·02:17 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·02:17 AM
Affected Software
Exploit Published
via GitHub·07:51 AM
Oct 16, 2026
Advisory Published
via OSV·09:05 AM
Oct 25, 2026
Data Sourced
via Microsoft·08:02 AM
DescriptionSeverityWeaknessAffected Software
Oct 29, 2026
Data Sourced
via CISA·12:00 AM
RemedyDescriptionWeaknessAffected Software

Frequently Asked Questions

1

Which GitLab versions need remediation?

GitLab CE/EE versions 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 are affected. Upgrade to 19.2.8, 19.3.5, 19.4.2, or a later version in the applicable release line.

2

Does exploitation require an authenticated GitLab account or user interaction?

No. The issue could allow an unauthenticated user to execute arbitrary code on the GitLab server, and the provided vector indicates no user interaction is required.

3

What input is involved in exploitation?

Exploitation involves a specially crafted regular expression in a CI/CD configuration. The issue is attributed to insufficient regular-expression validation under certain conditions.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203