OESA-2026-4635: httpd security update

Published Oct 29, 2026
·
Updated

Apache HTTP Server is a powerful and flexible HTTP/1.1 compliant web server. Security Fix(es):

Missing authentication checks in modauthdigest in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an unauthenticated remote client to cause a denial of service (forced re-authentication) via forged Authorization headers when Digest authentication is enabled with AuthDigestNcCheck .

Users are recommended to upgrade to version 2.4.69, which fixes this issue.(CVE-2026-48005)

Authentication bypass by capture-replay in modauthdigest in Apache Software Foundation Apache HTTP Server 2.4.x on all platforms allows a man-in-the-middle (MITM) attacker to replay captured digest authentication credentials via crafted requests that trigger garbage collection of the client's shared memory entry when AuthDigestNonceLifetime is set to 0.

Users are recommended to upgrade to version 2.4.69, which fixes this issue.(CVE-2026-73636)

Use after free in modauthdigest in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an unauthenticated remote client to cause authentication state corruption via concurrent Digest authentication requests when AuthDigestNcCheck is enabled or AuthDigestNonceLifetime is set to 0.

Users are recommended to upgrade to version 2.4.69, which fixes this issue.(CVE-2026-73637)

Affected Software

1 affected componentFixes available
openeuler/httpd<2.4.51-38.oe2203sp4
2.4.51-38.oe2203sp4

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade openeuler/httpd to a version that resolves this vulnerability.

    Fixed in 2.4.51-38.oe2203sp4
  2. Upgrade

    Upgrade Apache HTTP Server to a version that resolves this vulnerability.

    Fixed in 2.4.69

Event History

Oct 29, 2026
Advisory Published
via OSV·09:03 AM
Data Sourced
via OSV·09:03 AM
DescriptionSeverityAffected Software

Child vulnerabilities

Contains the following vulnerabilities.

Frequently Asked Questions

1

Which deployments are exposed to the forced re-authentication issue?

Deployments using mod_auth_digest are exposed when Digest authentication is enabled with AuthDigestNcCheck. The issue affects Apache HTTP Server versions before 2.4.69 on all platforms.

2

What access does an attacker need?

The forced re-authentication and authentication-state-corruption issues can be triggered by an unauthenticated remote client. The credential replay issue requires a man-in-the-middle attacker who can capture digest authentication credentials.

3

Which configuration makes the credential replay issue relevant?

The replay issue applies to Apache HTTP Server 2.4.x installations using mod_auth_digest when AuthDigestNonceLifetime is set to 0. Under that condition, crafted requests can trigger garbage collection of the client's shared-memory entry and enable replay of captured credentials.

4

What should be done if an affected configuration is identified?

Upgrade Apache HTTP Server to version 2.4.69, which is identified as fixing these issues. Review Digest authentication configurations for AuthDigestNcCheck and AuthDigestNonceLifetime set to 0 to determine whether the described conditions are present.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203