USN-7429-2: Linux kernel (FIPS) vulnerabilities
Several security issues were discovered in the Linux kernel. An attacker could possibly use these to compromise the system. This update corrects flaws in the following subsystems:
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/linux-image-4.4.0-1112-fipsto a version that resolves this vulnerability.Fixed in FIPS-140 - Upgrade
Upgrade
ubuntu/linux-image-fipsto a version that resolves this vulnerability.Fixed in FIPS-140 - Upgrade
Upgrade
ubuntu/linux-fipsto a version that resolves this vulnerability.Fixed in 4.4.0-1112.119 - Upgrade
Upgrade
Linux kernel (FIPS)to a version that resolves this vulnerability.Patch USN-7429-2
Event History
Child vulnerabilities
Contains the following vulnerabilities.
- CVE-2025-21702
- CVE-2025-21700
- CVE-2024-56658
- CVE-2024-56600
- CVE-2024-56595
- CVE-2024-53227
- CVE-2024-53165
- CVE-2024-50302
- CVE-2024-50265
- CVE-2024-50167
- CVE-2021-47119
- CVE-2021-47122
- CVE-2021-47235
- CVE-2021-47320
- CVE-2021-47483
- CVE-2021-47602
- CVE-2024-26863
- CVE-2024-26921
- CVE-2024-46826
- CVE-2024-49948
- CVE-2024-49952
- UBUNTU-CVE-2021-47119
- UBUNTU-CVE-2021-47122
- UBUNTU-CVE-2021-47235
- UBUNTU-CVE-2021-47320
- UBUNTU-CVE-2021-47483
- UBUNTU-CVE-2021-47602
- UBUNTU-CVE-2024-26863
- UBUNTU-CVE-2024-26921
- UBUNTU-CVE-2024-46826
- UBUNTU-CVE-2024-49948
- UBUNTU-CVE-2024-49952
- UBUNTU-CVE-2024-50167
- UBUNTU-CVE-2024-50265
- UBUNTU-CVE-2024-50302
- UBUNTU-CVE-2024-53165
- UBUNTU-CVE-2024-53227
- UBUNTU-CVE-2024-56595
- UBUNTU-CVE-2024-56600
- UBUNTU-CVE-2024-56658
- UBUNTU-CVE-2025-21700
- UBUNTU-CVE-2025-21702
Frequently Asked Questions
What is the severity of USN-7429-2?
USN-7429-2 addresses several critical security vulnerabilities in the Linux kernel that could allow attackers to compromise the system.
How do I fix USN-7429-2?
To fix USN-7429-2, you should update your Linux kernel to version 4.4.0-1112.119 or later.
What systems are affected by USN-7429-2?
USN-7429-2 primarily affects Ubuntu 16.04 systems running specific versions of the Linux kernel.
Who is responsible for addressing USN-7429-2?
System administrators and users of affected Ubuntu systems are responsible for applying the necessary updates for USN-7429-2.
What impact could USN-7429-2 have on my system?
If not addressed, the vulnerabilities in USN-7429-2 could potentially allow an attacker to gain unauthorized access or execute arbitrary code on your system.