CVE-2019-11598: High severity IBM Data Risk Manager vulnerability

Published Apr 29, 2019
·
Updated

ImageMagick is vulnerable to a denial of service, caused by a heap-based buffer over-read in the WritePNMImage function in coders/pnm.c. By persuading a victim to open a specially-crafted file, a remote attacker could exploit this vulnerability to cause a denial of service or possibly obtain sensitive information.

Other sources

In ImageMagick 7.0.8-40 Q16, there is a heap-based buffer over-read in the function WritePNMImage of coders/pnm.c, which allows an attacker to cause a denial of service or possibly information disclosure via a crafted image file.

Upstream issue: https://github.com/ImageMagick/ImageMagick/issues/1540

— Red Hat

In ImageMagick 7.0.8-40 Q16, there is a heap-based buffer over-read in the function WritePNMImage of coders/pnm.c, which allows an attacker to cause a denial of service or possibly information disclosure via a crafted image file. This is related to SetGrayscaleImage in MagickCore/quantize.c.

— Launchpad

Affected Software

32 affected componentsFixes available
redhat/image magick 6.9.10<40
40
redhat/imagemagick 7.0.8<40
40
IBM Data Risk Manager<=2.0.6
ImageMagick ImageMagick=7.0.8-40-q16
debian/imagemagick
8:6.9.11.60+dfsg-1.3+deb11u48:6.9.11.60+dfsg-1.3+deb11u58:6.9.11.60+dfsg-1.6+deb12u28:6.9.11.60+dfsg-1.6+deb12u18:7.1.1.43+dfsg1-18:7.1.1.47+dfsg1-1
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick<7.0.8.44-r0
7.0.8.44-r0
alpine/imagemagick6<6.9.10.43-r0
6.9.10.43-r0
alpine/imagemagick6<6.9.10.43-r0
6.9.10.43-r0
alpine/imagemagick6<6.9.10.43-r0
6.9.10.43-r0
alpine/imagemagick6<6.9.10.43-r0
6.9.10.43-r0
alpine/imagemagick6<6.9.10.43-r0
6.9.10.43-r0
alpine/imagemagick6<6.9.10.43-r0
6.9.10.43-r0
alpine/imagemagick6<6.9.10.43-r0
6.9.10.43-r0
alpine/imagemagick6<6.9.10.44-r0
6.9.10.44-r0
alpine/imagemagick6<6.9.10.44-r0
6.9.10.44-r0
alpine/imagemagick6<6.9.10.44-r0
6.9.10.44-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/Image Magick 6.9.10 to a version that resolves this vulnerability.

    Fixed in 40
  2. Upgrade

    Upgrade redhat/ImageMagick 7.0.8 to a version that resolves this vulnerability.

    Fixed in 40
  3. Upgrade

    Upgrade debian/imagemagick to a version that resolves this vulnerability.

    Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u5Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1

Event History

Apr 29, 2019
CVE Published
via MITRE·03:06 PM
Data Sourced
via MITRE·03:06 PM
Description
Data Sourced
via NVD·04:29 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·04:29 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the vulnerability ID?

The vulnerability ID is CVE-2019-11598.

2

What is the severity of CVE-2019-11598?

The severity of CVE-2019-11598 is high.

3

How does the vulnerability in ImageMagick affect the software?

The vulnerability in ImageMagick can cause a denial of service or possibly obtain sensitive information.

4

Which versions of ImageMagick are affected by CVE-2019-11598?

Versions 7.0.8-40 Q16 of ImageMagick are affected by CVE-2019-11598.

5

Where can I find more information about CVE-2019-11598?

You can find more information about CVE-2019-11598 at the following references: [link1](http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00057.html), [link2](http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00001.html), [link3](http://www.securityfocus.com/bid/108102).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203