CVE-2019-13297: Buffer Overflow

Published Jul 5, 2019
·
Updated

ImageMagick 7.0.8-50 Q16 has a heap-based buffer over-read at MagickCore/threshold.c in AdaptiveThresholdImage because a height of zero is mishandled.

Other sources

ImageMagick is vulnerable to a heap-based buffer overflow, caused by improper bounds checking by AdaptiveThresholdImage in MagickCore/threshold.c. By sending a specially crafted command, a local attacker could overflow a buffer and execute arbitrary code on the system or cause the application to crash.

— IBM

Affected Software

41 affected componentsFixes available
redhat/imagemagick 6.9.10<50
50
redhat/imagemagick 7.0.8<50
50
IBM Data Risk Manager<=2.0.6
ImageMagick ImageMagick=7.0.8-50-q16
Debian Debian Linux=8.0
Debian Debian Linux=9.0
Debian Debian Linux=10.0
Canonical Ubuntu Linux=16.04
Canonical Ubuntu Linux=18.04
Canonical Ubuntu Linux=19.04
Canonical Ubuntu Linux=19.10
openSUSE Leap=15.0
openSUSE Leap=15.1
debian/imagemagick
8:6.9.11.60+dfsg-1.3+deb11u48:6.9.11.60+dfsg-1.3+deb11u38:6.9.11.60+dfsg-1.6+deb12u28:6.9.11.60+dfsg-1.6+deb12u18:7.1.1.43+dfsg1-18:7.1.1.47+dfsg1-1
alpine/imagemagick<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<7.0.8.53-r0
7.0.8.53-r0
alpine/imagemagick<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick6<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick6<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick6<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick6<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick6<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick6<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick6<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick6<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick6<6.9.10.53-r0
6.9.10.53-r0
alpine/imagemagick6<6.9.10.53-r0
6.9.10.53-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/ImageMagick 6.9.10 to a version that resolves this vulnerability.

    Fixed in 50
  2. Upgrade

    Upgrade redhat/ImageMagick 7.0.8 to a version that resolves this vulnerability.

    Fixed in 50
  3. Upgrade

    Upgrade debian/imagemagick to a version that resolves this vulnerability.

    Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u3Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1

Event History

Jul 5, 2019
CVE Published
via MITRE·12:51 AM
Data Sourced
via MITRE·12:51 AM
Description
Data Sourced
via NVD·01:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·01:15 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is CVE-2019-13297?

CVE-2019-13297 is a vulnerability in ImageMagick that allows a local attacker to execute arbitrary code or cause a denial of service.

2

What is the severity of CVE-2019-13297?

The severity of CVE-2019-13297 is high with a CVSS score of 8.8.

3

Which software versions are affected by CVE-2019-13297?

ImageMagick 7.0.8-50 Q16 and Debian Linux versions 8.0, 9.0, and 10.0 are affected by CVE-2019-13297.

4

How can I fix CVE-2019-13297?

Apply the necessary patches or updates provided by the software vendors to fix CVE-2019-13297.

5

Where can I find more information about CVE-2019-13297?

You can find more information about CVE-2019-13297 on the CVE Details website, Ubuntu security notices, and the NIST National Vulnerability Database.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203