CVE-2019-7398: High severity IBM Data Risk Manager vulnerability

Published Feb 5, 2019
·
Updated

ImageMagick is vulnerable to a denial of service, caused by a memory leak in WriteDIBImage in coders/dib.c. By persuading a victim to open a specially-crafted file, a remote attacker could exploit this vulnerability to cause the application to crash.

Other sources

In ImageMagick before 7.0.8-25, a memory leak exists in WriteDIBImage in coders/dib.c.

— Launchpad

Affected Software

22 affected componentsFixes available
redhat/imagemagick 6.9.10<25
25
redhat/imagemagick 7.0.8<25
25
IBM Data Risk Manager<=2.0.6
ImageMagick ImageMagick<6.9.10-25
ImageMagick ImageMagick>=7.0.0-0<7.0.8-25
openSUSE Leap=15.0
Debian Debian Linux=10.0
Canonical Ubuntu Linux=16.04
Canonical Ubuntu Linux=18.04
Canonical Ubuntu Linux=18.10
Canonical Ubuntu Linux=19.04
debian/imagemagick
8:6.9.11.60+dfsg-1.3+deb11u48:6.9.11.60+dfsg-1.3+deb11u58:6.9.11.60+dfsg-1.6+deb12u28:6.9.11.60+dfsg-1.6+deb12u18:7.1.1.43+dfsg1-18:7.1.1.47+dfsg1-1
alpine/imagemagick6<6.9.10.37-r0
6.9.10.37-r0
alpine/imagemagick6<6.9.10.37-r0
6.9.10.37-r0
alpine/imagemagick6<6.9.10.37-r0
6.9.10.37-r0
alpine/imagemagick6<6.9.10.37-r0
6.9.10.37-r0
alpine/imagemagick6<6.9.10.37-r0
6.9.10.37-r0
alpine/imagemagick6<6.9.10.37-r0
6.9.10.37-r0
alpine/imagemagick6<6.9.10.37-r0
6.9.10.37-r0
alpine/imagemagick6<6.9.10.39-r0
6.9.10.39-r0
alpine/imagemagick6<6.9.10.39-r0
6.9.10.39-r0
alpine/imagemagick6<6.9.10.39-r0
6.9.10.39-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/ImageMagick 6.9.10 to a version that resolves this vulnerability.

    Fixed in 25
  2. Upgrade

    Upgrade redhat/ImageMagick 7.0.8 to a version that resolves this vulnerability.

    Fixed in 25
  3. Upgrade

    Upgrade debian/imagemagick to a version that resolves this vulnerability.

    Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u5Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1
  4. Upgrade

    Upgrade ImageMagick to a version that resolves this vulnerability.

    Fixed in 7.0.8-25

Event History

Feb 5, 2019
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via OSV·12:29 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is CVE-2019-7398?

CVE-2019-7398 is a vulnerability in ImageMagick that allows a remote attacker to cause a denial of service by exploiting a memory leak in WriteDIBImage in coders/dib.c.

2

How severe is CVE-2019-7398?

CVE-2019-7398 has a severity rating of high with a CVSS score of 7.5.

3

Which versions of ImageMagick are affected by CVE-2019-7398?

CVE-2019-7398 affects ImageMagick versions up to 8:6.9.10.23+dfsg-2.1ubuntu2.

4

How can I fix CVE-2019-7398?

To fix CVE-2019-7398, apply the appropriate patch or update provided by the vendor or package maintainer.

5

Where can I find more information about CVE-2019-7398?

You can find more information about CVE-2019-7398 on the OpenSUSE Security Announce mailing list and the SecurityFocus website.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203