CVE-2019-9956: Buffer Overflow
ImageMagick is vulnerable to a stack-based buffer overflow, caused by improper bounds checking by the PopHexPixel function in coders/ps.c. By persuading a victim to open a specially-crafted file, a remote attacker could overflow a buffer and execute arbitrary code, or cause a denial of service condtion on the system.
Other sources
In ImageMagick 7.0.8-35 Q16, there is a stack-based buffer overflow in the function PopHexPixel of coders/ps.c, which allows an attacker to cause a denial of service or code execution via a crafted image file.
— Launchpad
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/ImageMagick 7.0.8to a version that resolves this vulnerability.Fixed in 35 - Upgrade
Upgrade
redhat/ImageMagick 6.9.10to a version that resolves this vulnerability.Fixed in 35 - Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u5Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1
Event History
Frequently Asked Questions
What is the vulnerability ID for ImageMagick?
The vulnerability ID for ImageMagick is CVE-2019-9956.
What is the severity of CVE-2019-9956?
The severity of CVE-2019-9956 is high (8.8).
Which software versions are affected by CVE-2019-9956?
ImageMagick version 7.0.8-35 Q16 and IBM Data Risk Manager version up to 2.0.6 are affected by CVE-2019-9956.
How can I fix the CVE-2019-9956 vulnerability?
Apply the latest patches or updates provided by the software vendors to fix the CVE-2019-9956 vulnerability.
Where can I find more information about CVE-2019-9956?
You can find more information about CVE-2019-9956 on the MITRE CVE website, Ubuntu Security Notices, and NIST NVD.