CVE-2021-23953: Medium severity Mozilla Thunderbird vulnerability
If a user clicked into a specifically crafted PDF, the PDF reader could be confused into leaking cross-origin information, when said information is served as chunked data.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 118.0.2-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 91.12.0esr-1~deb10u1Fixed in 115.3.1esr-1~deb10u1Fixed in 102.15.0esr-1~deb11u1Fixed in 115.3.1esr-1~deb11u1Fixed in 102.15.1esr-1~deb12u1Fixed in 115.3.0esr-1~deb12u1Fixed in 115.3.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:91.12.0-1~deb10u1Fixed in 1:115.3.1-1~deb10u1Fixed in 1:102.13.1-1~deb11u1Fixed in 1:115.3.1-1~deb11u1Fixed in 1:102.15.1-1~deb12u1Fixed in 1:115.3.1-1~deb12u1Fixed in 1:115.3.1-1 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 78.7 - Upgrade
Upgrade
Firefoxto a version that resolves this vulnerability.Fixed in 85 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 78.7 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 78.7.0-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 78.7.0-r0
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2021-23953?
CVE-2021-23953 has a severity rating that indicates it can lead to the leakage of sensitive cross-origin information.
How do I fix CVE-2021-23953?
To fix CVE-2021-23953, update Mozilla Firefox, Firefox ESR, or Thunderbird to versions later than 85, 78.7 respectively.
Which software is affected by CVE-2021-23953?
CVE-2021-23953 affects specific versions of Mozilla Thunderbird and Firefox, including 78.7 or earlier versions.
Can CVE-2021-23953 be exploited remotely?
Yes, CVE-2021-23953 can be exploited remotely if a user interacts with a specially crafted PDF.
What type of vulnerability is CVE-2021-23953?
CVE-2021-23953 is a cross-origin information leakage vulnerability related to the handling of chunked data in PDF files.