CVE-2021-23954: High severity Mozilla Thunderbird vulnerability
Using the new logical assignment operators in a JavaScript switch statement could have caused a type confusion, leading to a memory corruption and a potentially exploitable crash.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 118.0.2-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 91.12.0esr-1~deb10u1Fixed in 115.3.1esr-1~deb10u1Fixed in 102.15.0esr-1~deb11u1Fixed in 115.3.1esr-1~deb11u1Fixed in 102.15.1esr-1~deb12u1Fixed in 115.3.0esr-1~deb12u1Fixed in 115.3.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:91.12.0-1~deb10u1Fixed in 1:115.3.1-1~deb10u1Fixed in 1:102.13.1-1~deb11u1Fixed in 1:115.3.1-1~deb11u1Fixed in 1:102.15.1-1~deb12u1Fixed in 1:115.3.1-1~deb12u1Fixed in 1:115.3.1-1 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 78.7 - Upgrade
Upgrade
Firefoxto a version that resolves this vulnerability.Fixed in 85 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 78.7 - Upgrade
Upgrade
alpine/firefoxto a version that resolves this vulnerability.Fixed in 85.0-r0 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 78.7.0-r0 - Upgrade
Upgrade
alpine/librewolfto a version that resolves this vulnerability.Fixed in 85.0-r0 - Upgrade
Upgrade
alpine/mozjs78to a version that resolves this vulnerability.Fixed in 78.7.0-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 78.7.0-r0
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2021-23954?
CVE-2021-23954 is classified as a high severity vulnerability due to potential memory corruption and crash exploitation.
How do I fix CVE-2021-23954?
To fix CVE-2021-23954, update your software to Mozilla Thunderbird version 78.7 or higher, Mozilla Firefox version 85 or higher, or Mozilla Firefox ESR version 78.7 or higher.
What software is affected by CVE-2021-23954?
CVE-2021-23954 affects Mozilla Thunderbird versions up to 78.7, Mozilla Firefox versions up to 85, and Mozilla Firefox ESR versions up to 78.7.
What type of vulnerability is CVE-2021-23954?
CVE-2021-23954 is a type confusion vulnerability that could result in memory corruption.
What can happen if I don't address CVE-2021-23954?
If CVE-2021-23954 is not addressed, it may lead to crashes or potential exploitation of the affected software.