CVE-2021-38503: Critical severity Mozilla Thunderbird vulnerability
The iframe sandbox rules were not correctly applied to XSLT stylesheets, allowing an iframe to bypass restrictions such as executing scripts or navigating the top-level frame.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 118.0.2-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 91.12.0esr-1~deb10u1Fixed in 115.3.1esr-1~deb10u1Fixed in 102.15.0esr-1~deb11u1Fixed in 115.3.1esr-1~deb11u1Fixed in 102.15.1esr-1~deb12u1Fixed in 115.3.0esr-1~deb12u1Fixed in 115.3.0esr-1Fixed in 115.4.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:91.12.0-1~deb10u1Fixed in 1:115.3.1-1~deb10u1Fixed in 1:102.13.1-1~deb11u1Fixed in 1:115.3.1-1~deb11u1Fixed in 1:102.15.1-1~deb12u1Fixed in 1:115.3.1-1~deb12u1Fixed in 1:115.3.1-1 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 91.3 - Upgrade
Upgrade
Firefoxto a version that resolves this vulnerability.Fixed in 94 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 91.3 - Upgrade
Upgrade
alpine/firefoxto a version that resolves this vulnerability.Fixed in 94.0-r0 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 91.3.0-r0 - Upgrade
Upgrade
alpine/librewolfto a version that resolves this vulnerability.Fixed in 94.0-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 91.3.2-r0
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the CVE ID for this vulnerability?
The CVE ID for this vulnerability is CVE-2021-38503.
Which software products are affected by this vulnerability?
This vulnerability affects Firefox versions earlier than 94, Thunderbird versions earlier than 91.3, and Firefox ESR versions earlier than 91.3.
What is the severity of CVE-2021-38503?
CVE-2021-38503 has a severity rating of critical.
How can I fix this vulnerability?
To fix this vulnerability, update your Firefox to version 94 or later, Thunderbird to version 91.3 or later, or Firefox ESR to version 91.3 or later.
Where can I find more information about CVE-2021-38503?
You can find more information about CVE-2021-38503 in the following references: [link1], [link2], [link3].