CVE-2021-38508: Medium severity Mozilla Thunderbird vulnerability
By displaying a form validity message in the correct location at the same time as a permission prompt (such as for geolocation), the validity message could have obscured the prompt, resulting in the user potentially being tricked into granting the permission.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 118.0.2-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 91.12.0esr-1~deb10u1Fixed in 115.3.1esr-1~deb10u1Fixed in 102.15.0esr-1~deb11u1Fixed in 115.3.1esr-1~deb11u1Fixed in 102.15.1esr-1~deb12u1Fixed in 115.3.0esr-1~deb12u1Fixed in 115.3.0esr-1Fixed in 115.4.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:91.12.0-1~deb10u1Fixed in 1:115.3.1-1~deb10u1Fixed in 1:102.13.1-1~deb11u1Fixed in 1:115.3.1-1~deb11u1Fixed in 1:102.15.1-1~deb12u1Fixed in 1:115.3.1-1~deb12u1Fixed in 1:115.3.1-1 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 91.3 - Upgrade
Upgrade
Firefoxto a version that resolves this vulnerability.Fixed in 94 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 91.3 - Upgrade
Upgrade
alpine/firefoxto a version that resolves this vulnerability.Fixed in 94.0-r0 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 91.3.0-r0 - Upgrade
Upgrade
alpine/librewolfto a version that resolves this vulnerability.Fixed in 94.0-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 91.3.2-r0
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is CVE-2021-38508?
CVE-2021-38508 is a vulnerability that could potentially trick users into granting permissions by obscuring permission prompts with form validity messages.
Which software products are affected by CVE-2021-38508?
Firefox ESR < 91.3, Thunderbird < 91.3, and Firefox < 94 are affected by CVE-2021-38508.
What is the severity of CVE-2021-38508?
CVE-2021-38508 has a severity level of medium (4).
How can I fix CVE-2021-38508?
Update your Firefox ESR to version 91.3 or newer, Thunderbird to version 91.3 or newer, or Firefox to version 94 or newer to fix CVE-2021-38508.
Where can I find more information about CVE-2021-38508?
You can find more information about CVE-2021-38508 on the Mozilla Bugzilla and Mozilla Security Advisories websites.