CVE-2022-22742: Medium severity Mozilla Firefox vulnerability
When inserting text while in edit mode, some characters might have lead to out-of-bounds memory access causing a potentially exploitable crash.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 91.5 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 91.5 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 96 - Upgrade
Upgrade
alpine/firefoxto a version that resolves this vulnerability.Fixed in 97.0-r0 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 91.5.0-r0 - Upgrade
Upgrade
alpine/librewolfto a version that resolves this vulnerability.Fixed in 97.0-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 91.5.0-r0 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 91.5.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:91.5.0-1 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2022-22742?
CVE-2022-22742 is classified as a potentially exploitable security vulnerability due to out-of-bounds memory access.
How do I fix CVE-2022-22742?
To fix CVE-2022-22742, users should update to versions of Firefox and Thunderbird later than those listed as affected.
Which software is affected by CVE-2022-22742?
CVE-2022-22742 affects Mozilla Firefox ESR versions prior to 91.5, Firefox versions prior to 96, and Thunderbird versions prior to 91.5.
What type of vulnerability is CVE-2022-22742?
CVE-2022-22742 is an out-of-bounds memory access vulnerability that can lead to application crashes.
Can CVE-2022-22742 be exploited remotely?
The exploitation potential of CVE-2022-22742 could lead to crashes but may also allow for remote code execution under certain conditions.