CVE-2022-22748: XSS
Malicious websites could have confused Firefox into showing the wrong origin when asking to launch a program and handling an external URL protocol.
Other sources
Malicious websites could have confused Thunderbird into showing the wrong origin when asking to launch a program and handling an external URL protocol.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 91.5 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 91.5 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 96 - Upgrade
Upgrade
alpine/firefoxto a version that resolves this vulnerability.Fixed in 97.0-r0 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 91.5.0-r0 - Upgrade
Upgrade
alpine/librewolfto a version that resolves this vulnerability.Fixed in 97.0-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 91.5.0-r0 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 91.5.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:91.5.0-1 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2022-22748?
The severity of CVE-2022-22748 is classified as high.
How do I fix CVE-2022-22748?
To fix CVE-2022-22748, update to Firefox version 96 or later, or Firefox ESR version 91.5 or later.
What software is affected by CVE-2022-22748?
CVE-2022-22748 affects Mozilla Firefox, Firefox ESR, and Thunderbird versions prior to their respective fixed releases.
What type of vulnerability is CVE-2022-22748?
CVE-2022-22748 is a security vulnerability that allows malicious websites to mislead users about the program origin when launching external programs.
When was CVE-2022-22748 disclosed?
CVE-2022-22748 was disclosed in early 2022.