CVE-2022-22754: Medium severity Mozilla Firefox vulnerability
If a user installed an extension of a particular type, the extension could have auto-updated itself and while doing so, bypass the prompt which grants the new version the new requested permissions.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 91.6 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 97 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 91.6 - Upgrade
Upgrade
alpine/firefoxto a version that resolves this vulnerability.Fixed in 97.0-r0 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 91.6.0-r0 - Upgrade
Upgrade
alpine/librewolfto a version that resolves this vulnerability.Fixed in 97.0-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 91.6.0-r0 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 91.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:91.6.0-1 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the vulnerability ID for this issue?
The vulnerability ID for this issue is CVE-2022-22754.
Which software versions are affected by this vulnerability?
This vulnerability affects Firefox < 97, Thunderbird < 91.6, and Firefox ESR < 91.6.
What is the severity of CVE-2022-22754?
The severity of CVE-2022-22754 is high with a CVSS score of 6.5.
How can I fix the vulnerability in Firefox?
To fix the vulnerability in Firefox, update to version 97 or later.
How can I fix the vulnerability in Thunderbird?
To fix the vulnerability in Thunderbird, update to version 91.6 or later.
How can I fix the vulnerability in Firefox ESR?
To fix the vulnerability in Firefox ESR, update to version 91.6 or later.