CVE-2022-22760: Medium severity Mozilla Firefox vulnerability
When importing resources using Web Workers, error messages would distinguish the difference between <code>application/javascript</code> responses and non-script responses. This could have been abused to learn information cross-origin. This vulnerability affects Firefox < 97, Thunderbird < 91.6, and Firefox ESR < 91.6.
Other sources
When importing resources using Web Workers, error messages would distinguish the difference between application/javascript responses and non-script responses. This could have been abused to learn information cross-origin.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 91.6 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 97 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 91.6 - Upgrade
Upgrade
alpine/firefoxto a version that resolves this vulnerability.Fixed in 97.0-r0 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 91.6.0-r0 - Upgrade
Upgrade
alpine/librewolfto a version that resolves this vulnerability.Fixed in 97.0-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 91.6.0-r0 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 91.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:91.6.0-1 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is CVE-2022-22760?
CVE-2022-22760 is a vulnerability that affected Mozilla Firefox, Firefox ESR, and Thunderbird versions up to 91.6.
How does CVE-2022-22760 impact web workers?
CVE-2022-22760 allowed error messages when importing resources using web workers to distinguish between application/javascript responses and non-script responses, potentially leaking cross-origin information.
Which software versions are affected by CVE-2022-22760?
CVE-2022-22760 affected Mozilla Firefox versions up to 97, Firefox ESR versions up to 91.6, and Thunderbird versions up to 91.6.
What is the severity of CVE-2022-22760?
CVE-2022-22760 has a severity level of medium with a CVSS score of 4.
How can I fix CVE-2022-22760?
To fix CVE-2022-22760, update your Mozilla Firefox, Firefox ESR, or Thunderbird to version 91.6 (for Firefox ESR) or 97 (for Firefox).