CVE-2022-32912: Buffer Overflow
Accelerate Framework. A memory consumption issue was addressed with improved memory handling.
Other sources
An out-of-bounds read was addressed with improved bounds checking. This issue is fixed in Safari 16, iOS 16, iOS 15.7 and iPadOS 15.7. Processing maliciously crafted web content may lead to arbitrary code execution.
— MITRE
APFS. An access issue was addressed with improved access restrictions.
— Apple
Apple Neural Engine. The issue was addressed with improved memory handling.
— Apple
AppleAVD. A memory corruption issue was addressed with improved state management.
— Apple
AppleAVD. This issue was addressed with improved checks.
— Apple
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
tvOSto a version that resolves this vulnerability.Fixed in 16 - Upgrade
Upgrade
Apple iOS, iPadOS, and watchOSto a version that resolves this vulnerability.Fixed in 9 - Upgrade
Upgrade
macOS Venturato a version that resolves this vulnerability.Fixed in 13 - Upgrade
Upgrade
Safarito a version that resolves this vulnerability.Fixed in 16 - Upgrade
Upgrade
Apple iOS and iPadOSto a version that resolves this vulnerability.Fixed in 16 - Upgrade
Upgrade
Apple iOS and iPadOSto a version that resolves this vulnerability.Fixed in 15.7 - Upgrade
Upgrade
Apple iOS, iPadOS, and macOSto a version that resolves this vulnerability.Fixed in 15.7 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 13 - Upgrade
Upgrade
Rubyto a version that resolves this vulnerability.Fixed in 2.6.10 - Upgrade
Upgrade
curlto a version that resolves this vulnerability.Fixed in 7.84.0 - Upgrade
Upgrade
iOSto a version that resolves this vulnerability.Fixed in 16 - Upgrade
Upgrade
iOSto a version that resolves this vulnerability.Fixed in 15.7 - Upgrade
Upgrade
iPadOSto a version that resolves this vulnerability.Fixed in 15.7
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
- CVE-2022-42795
- CVE-2022-32907
- CVE-2022-32903
- CVE-2022-1622
- CVE-2022-32913
- CVE-2022-32949
- CVE-2022-32864
- CVE-2022-32866
- CVE-2022-32911
- CVE-2022-32914
- CVE-2022-32908
- CVE-2022-32879
- CVE-2022-32881
- CVE-2021-36690
- CVE-2022-32886
- CVE-2022-32888
- CVE-2022-32912
- CVE-2022-32891
- CVE-2022-46709
- CVE-2022-32925
- CVE-2022-32858
- CVE-2022-32898
- CVE-2022-32899
- CVE-2022-32889
- CVE-2022-32854
- CVE-2022-32928
- CVE-2022-32894
- CVE-2022-32883
- CVE-2022-32870
- CVE-2022-32835
- CVE-2022-32875
- CVE-2022-32893
- CVE-2022-48577
- CVE-2022-46721
- CVE-2022-47915
- CVE-2022-47965
- CVE-2022-32827
- CVE-2022-32877
- CVE-2022-42789
- CVE-2022-42825
- CVE-2022-46722
- CVE-2022-32902
- CVE-2022-32904
- CVE-2022-32890
- CVE-2022-42796
- CVE-2022-42798
- CVE-2022-32940
- CVE-2022-42816
- CVE-2022-42821
- CVE-2022-42860
- CVE-2022-42819
- CVE-2022-42813
- CVE-2022-26730
- CVE-2022-32945
- CVE-2022-42838
- CVE-2022-48683
- CVE-2022-22663
- CVE-2022-32867
- CVE-2022-32205
- CVE-2022-32206
- CVE-2022-32207
- CVE-2022-32208
- CVE-2022-42814
- CVE-2022-32865
- CVE-2022-32915
- CVE-2022-22643
- CVE-2022-32935
- CVE-2022-42788
- CVE-2022-48504
- CVE-2022-32905
- CVE-2022-42833
- CVE-2022-32947
- CVE-2022-42809
- CVE-2022-3437
- CVE-2022-32849
- CVE-2022-32809
- CVE-2022-32936
- CVE-2022-42820
- CVE-2022-42806
- CVE-2022-32924
- CVE-2022-42808
- CVE-2022-32944
- CVE-2022-42803
- CVE-2022-32926
- CVE-2022-42801
- CVE-2022-46712
- CVE-2022-42815
- CVE-2022-42834
- CVE-2022-46707
- CVE-2022-42810
- CVE-2021-39537
- CVE-2022-29458
- CVE-2022-42818
- CVE-2022-32895
- CVE-2022-46713
- CVE-2022-42807
- CVE-2022-32918
- CVE-2022-42829
- CVE-2022-42830
- CVE-2022-42831
- CVE-2022-42832
- CVE-2022-32941
- CVE-2022-28739
- CVE-2022-32862
- CVE-2022-32931
- CVE-2022-42811
- CVE-2022-42793
- CVE-2022-32876
- CVE-2022-32938
- CVE-2022-42790
- CVE-2022-32934
- CVE-2022-42791
- CVE-2022-48505
- CVE-2022-26699
- CVE-2022-0261
- CVE-2022-0318
- CVE-2022-0319
- CVE-2022-0351
- CVE-2022-0359
- CVE-2022-0361
- CVE-2022-0368
- CVE-2022-0392
- CVE-2022-0554
- CVE-2022-0572
- CVE-2022-0629
- CVE-2022-0685
- CVE-2022-0696
- CVE-2022-0714
- CVE-2022-0729
- CVE-2022-0943
- CVE-2022-1381
- CVE-2022-1420
- CVE-2022-1725
- CVE-2022-1616
- CVE-2022-1619
- CVE-2022-1620
- CVE-2022-1621
- CVE-2022-1629
- CVE-2022-1674
- CVE-2022-1733
- CVE-2022-1735
- CVE-2022-1769
- CVE-2022-1927
- CVE-2022-1942
- CVE-2022-1968
- CVE-2022-1851
- CVE-2022-1897
- CVE-2022-1898
- CVE-2022-1720
- CVE-2022-2000
- CVE-2022-2042
- CVE-2022-2124
- CVE-2022-2125
- CVE-2022-2126
- CVE-2022-42828
- CVE-2022-42826
- CVE-2022-42799
- CVE-2022-42823
- CVE-2022-42824
- CVE-2022-32923
- CVE-2022-32922
- CVE-2022-32892
- CVE-2022-32833
- CVE-2022-37434
- CVE-2022-42800
- CVE-2022-32868
- CVE-2022-32909
- CVE-2022-32793
- CVE-2022-26744
- CVE-2022-32887
- CVE-2022-32916
- CVE-2022-32917
- CVE-2022-32795
- CVE-2022-32872
- CVE-2022-32871
- CVE-2022-32859
- CVE-2022-32929
Frequently Asked Questions
What is CVE-2022-32912?
CVE-2022-32912 is a vulnerability in WebKit that allows an out-of-bounds read.
Which software versions are affected by CVE-2022-32912?
Apple iOS versions up to and excluding 16, Apple iPadOS versions up to and excluding 15.7, Apple tvOS versions up to and excluding 16, Apple watchOS versions up to and excluding 9, Apple Safari versions up to and excluding 16, and macOS Ventura versions up to and excluding 13 are affected by CVE-2022-32912.
How can I fix CVE-2022-32912?
To fix CVE-2022-32912, it is recommended to update your Apple software to the latest available version provided by Apple.
Where can I find more information about CVE-2022-32912?
You can find more information about CVE-2022-32912 on the Apple support website. Here are the references: [link1], [link2], [link3].