CVE-2022-42927: High severity Mozilla Firefox vulnerability
A same-origin policy violation could have allowed the theft of cross-origin URL entries, leaking the result of a redirect, via performance.getEntries(). This vulnerability affects Firefox < 106, Firefox ESR < 102.4, and Thunderbird < 102.4.
Other sources
A same-origin policy violation could have allowed the theft of cross-origin URL entries, leaking the result of a redirect, via performance.getEntries().
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Firefoxto a version that resolves this vulnerability.Fixed in 106 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 102.4 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 106 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 102.4.0-r0 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 102.4.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:102.4.0-1 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the vulnerability ID of this security issue?
The vulnerability ID is CVE-2022-42927.
What is the severity rating of CVE-2022-42927?
CVE-2022-42927 has a severity rating of 8.1 (high).
Which software versions are affected by CVE-2022-42927?
Mozilla Firefox versions before 106, Mozilla Firefox ESR versions before 102.4, and Mozilla Thunderbird versions before 102.4 are affected by CVE-2022-42927.
How can CVE-2022-42927 be exploited?
CVE-2022-42927 can be exploited by violating the same-origin policy and stealing cross-origin URL entries, leaking the result of a redirect via performance.getEntries().
Are there any references or additional information available for CVE-2022-42927?
Yes, for more information on CVE-2022-42927, you can refer to the following sources: [Mozilla Bugzilla](https://bugzilla.mozilla.org/show_bug.cgi?id=1789128), [Mozilla Security Advisories](https://www.mozilla.org/en-US/security/advisories/mfsa2022-44/).