CVE-2022-42929: Medium severity Mozilla Firefox vulnerability

Published Oct 18, 2022
·
Updated

If a website called window.print() in a particular way, it could cause a denial of service of the browser, which may persist beyond browser restart depending on the user's session restore settings. This vulnerability affects Firefox < 106, Firefox ESR < 102.4, and Thunderbird < 102.4.

Other sources

If a website called window.print() in a particular way, it could cause a denial of service of the browser, which may persist beyond browser restart depending on the user's session restore settings.

Affected Software

21 affected componentsFixes available
Mozilla Firefox<106.0
Mozilla Firefox ESR<102.4
Mozilla Thunderbird<102.4
Mozilla Firefox<106
106
Mozilla Firefox ESR<102.4
102.4
Mozilla Thunderbird<102.4
102.4
alpine/firefox-esr<102.4.0-r0
102.4.0-r0
alpine/firefox-esr<102.4.0-r0
102.4.0-r0
alpine/firefox-esr<102.4.0-r0
102.4.0-r0
alpine/firefox-esr<102.4.0-r0
102.4.0-r0
alpine/firefox-esr<102.4.0-r0
102.4.0-r0
alpine/firefox-esr<102.4.0-r0
102.4.0-r0
debian/firefox-esr<102.4.0esr-1
102.4.0esr-1
debian/firefox-esr<102.4.0esr-1
102.4.0esr-1
debian/firefox-esr<102.4.0esr-1
102.4.0esr-1
debian/thunderbird<1:102.4.0-1
1:102.4.0-1
debian/thunderbird<1:102.4.0-1
1:102.4.0-1
debian/thunderbird<1:102.4.0-1
1:102.4.0-1
debian/firefox
159.0.1-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Firefox to a version that resolves this vulnerability.

    Fixed in 106
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 102.4
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 106
  4. Upgrade

    Upgrade alpine/firefox-esr to a version that resolves this vulnerability.

    Fixed in 102.4.0-r0
  5. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 102.4.0esr-1
  6. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:102.4.0-1
  7. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0.1-1
  8. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  9. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1

Event History

Oct 18, 2022
CVE Published
12:00 AM
Data Sourced
via Mozilla·12:00 AM
DescriptionSeverityAffected Software
Dec 22, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionWeakness
Data Sourced
via NVD·08:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the vulnerability ID for this vulnerability?

The vulnerability ID for this vulnerability is CVE-2022-42929.

2

What is the severity of CVE-2022-42929?

The severity of CVE-2022-42929 is medium with a severity value of 6.5.

3

Which software products are affected by CVE-2022-42929?

The software products affected by CVE-2022-42929 are Mozilla Firefox versions up to 106, Mozilla Firefox ESR versions up to 102.4, and Mozilla Thunderbird versions up to 102.4.

4

How can the denial of service issue caused by CVE-2022-42929 be fixed?

To fix the denial of service issue caused by CVE-2022-42929, users should update their affected software products to the latest version provided by Mozilla.

5

Where can I find more information about CVE-2022-42929?

More information about CVE-2022-42929 can be found at the following references: [Bugzilla](https://bugzilla.mozilla.org/show_bug.cgi?id=1789439), [Mozilla Security Advisories](https://www.mozilla.org/en-US/security/advisories/mfsa2022-44/)

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203