CVE-2024-6601: Race condition in permission assignment

Published Jul 9, 2024
·
Updated

A race condition could lead to a cross-origin container obtaining permissions of the top-level origin.

Affected Software

18 affected componentsFixes available
redhat/firefox<115.13
115.13
redhat/thunderbird<115.13
115.13
Mozilla Thunderbird<128
128
Mozilla Firefox<128.0
Mozilla Firefox<128.0
Mozilla Thunderbird<128.0
debian/firefox
159.0-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1
Mozilla Firefox<128
128
Mozilla Firefox ESR<115.13
115.13
Mozilla Thunderbird<115.13
115.13
debian/firefox-esr<115.13.0esr-1~deb12u1
115.13.0esr-1~deb12u1
debian/firefox-esr<115.13.0esr-1
115.13.0esr-1
debian/firefox-esr<115.13.0esr-1
115.13.0esr-1
debian/thunderbird<1:115.13.0-1~deb12u1
1:115.13.0-1~deb12u1
debian/thunderbird<1:115.13.0-1
1:115.13.0-1
debian/thunderbird<1:115.13.0-1
1:115.13.0-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/firefox to a version that resolves this vulnerability.

    Fixed in 115.13
  2. Upgrade

    Upgrade redhat/thunderbird to a version that resolves this vulnerability.

    Fixed in 115.13
  3. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 128
  4. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0-1
  5. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  6. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
  7. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 128
  8. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 115.13
  9. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 115.13.0esr-1~deb12u1
  10. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 115.13.0esr-1
  11. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:115.13.0-1~deb12u1
  12. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:115.13.0-1
  13. Upgrade

    Upgrade Mozilla Firefox to a version that resolves this vulnerability.

    Fixed in 128
  14. Upgrade

    Upgrade Mozilla Firefox ESR to a version that resolves this vulnerability.

    Fixed in 115.13
  15. Upgrade

    Upgrade Mozilla Thunderbird to a version that resolves this vulnerability.

    Fixed in 128
  16. Upgrade

    Upgrade Mozilla Thunderbird to a version that resolves this vulnerability.

    Fixed in 115.13

Event History

Jul 9, 2024
CVE Published
via Mozilla·12:00 AM
Data Sourced
via Mozilla·12:00 AM
DescriptionSeverityAffected Software
CVE Published
via MITRE·02:25 PM
Data Sourced
via MITRE·02:25 PM
Description
Data Sourced
via NVD·03:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·03:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2024-6601?

CVE-2024-6601 has been classified as a high-severity vulnerability due to the potential for cross-origin exploitation.

2

How do I fix CVE-2024-6601?

To fix CVE-2024-6601, upgrade to Firefox version 128 or Thunderbird version 128, or apply the latest security updates provided by your distribution.

3

Which versions of Firefox are affected by CVE-2024-6601?

CVE-2024-6601 affects Firefox versions prior to 128 and Firefox ESR versions prior to 115.13.

4

Which users are at risk from CVE-2024-6601?

Users running affected versions of Firefox or Thunderbird are at risk of CVE-2024-6601 due to a race condition that could permit unauthorized access.

5

Is CVE-2024-6601 exploitable remotely?

Yes, CVE-2024-6601 is exploitable remotely, making it particularly concerning for users of affected software.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203