CVE-2024-7652: Type Confusion in Async Generators in Javascript Engine
An error in the ECMA-262 specification relating to Async Generators could have resulted in a type confusion, potentially leading to memory corruption and an exploitable crash.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 128 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 128 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 115.13 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 115.13.0esr-1~deb12u1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 115.13.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:115.13.0-1~deb12u1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:115.13.0-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2024-7652?
CVE-2024-7652 is classified as a high severity vulnerability due to its potential for memory corruption and exploitable crashes.
How do I fix CVE-2024-7652?
To fix CVE-2024-7652, update affected software such as Mozilla Firefox ESR to version 115.13 or later, or Mozilla Thunderbird to version 115.13 or later.
Which products are affected by CVE-2024-7652?
CVE-2024-7652 affects Mozilla Firefox versions up to 128, Mozilla Firefox ESR versions up to 115.13, and Thunderbird versions up to 128.
What types of vulnerabilities does CVE-2024-7652 relate to?
CVE-2024-7652 is related to a type confusion error in the ECMA-262 specification that impacts Async Generators.
Are there any known exploits for CVE-2024-7652?
As of now, there are no publicly known exploits specifically targeting CVE-2024-7652.