CVE-2025-1931: Use-after-free in WebTransportChild

Published Mar 4, 2025
·
Updated

It was possible to cause a use-after-free in the content process side of a WebTransport connection, leading to a potentially exploitable crash. This vulnerability was fixed in Firefox 136, Firefox ESR 115.21, Firefox ESR 128.8, Thunderbird 136, and Thunderbird 128.8.

Other sources

It was possible to cause a use-after-free in the content process side of a WebTransport connection, leading to a potentially exploitable crash. This vulnerability affects Firefox < 136, Firefox ESR < 115.21, and Firefox ESR < 128.8.

— Red Hat

Affected Software

26 affected componentsFixes available
Mozilla Firefox<136
Mozilla Firefox ESR<115.21, <128.8
Mozilla Firefox ESR<115.21
115.21
Mozilla Thunderbird<136
136
Mozilla Firefox<115.21.0
Mozilla Firefox<136.0
Mozilla Firefox>=116.0<128.8.0
Mozilla Thunderbird<128.8.0
Mozilla Thunderbird>=129.0<136.0
Mozilla Thunderbird<128.8
128.8
ubuntu/mozjs52*
ubuntu/mozjs38*
ubuntu/firefox<136.0+build3-0ubuntu0.20.04.1
136.0+build3-0ubuntu0.20.04.1
ubuntu/mozjs68*
ubuntu/mozjs52*
ubuntu/mozjs102*
ubuntu/mozjs78*
ubuntu/mozjs91*
ubuntu/thunderbird<1:128.12.0+build1-0ubuntu0.22.04.1
1:128.12.0+build1-0ubuntu0.22.04.1
ubuntu/mozjs102*
ubuntu/mozjs115*
Mozilla Firefox ESR<128.8
128.8
Mozilla Firefox<136
136
debian/firefox
159.0.1-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 115.21
  2. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 136
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 128.8
  4. Upgrade

    Upgrade ubuntu/firefox to a version that resolves this vulnerability.

    Fixed in 136.0+build3-0ubuntu0.20.04.1
  5. Upgrade

    Upgrade ubuntu/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:128.12.0+build1-0ubuntu0.22.04.1
  6. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 136
  7. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0.1-1
  8. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  9. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
  10. Upgrade

    Upgrade Firefox to a version that resolves this vulnerability.

    Fixed in 136
  11. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 128.8
  12. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 128.8

Event History

Mar 4, 2025
CVE Published
via Mozilla·12:00 AM
Data Sourced
via Mozilla·12:00 AM
DescriptionSeverityAffected Software
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·01:31 PM
Data Sourced
via MITRE·01:31 PM
Description
Data Sourced
via Red Hat·02:01 PM
DescriptionSeverityAffected Software
Data Sourced
via OSV·02:15 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·02:15 PM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2025-1931?

CVE-2025-1931 has been categorized as a potentially exploitable vulnerability that can lead to a crash.

2

How do I fix CVE-2025-1931?

To fix CVE-2025-1931, upgrade to Mozilla Firefox version 136 or Mozilla Firefox ESR versions 115.21 or 128.8.

3

What causes CVE-2025-1931?

CVE-2025-1931 is caused by a use-after-free error in the content process of a WebTransport connection.

4

Which software versions are affected by CVE-2025-1931?

Affected software includes Mozilla Firefox versions up to 136 and Mozilla Firefox ESR versions up to 115.21 and 128.8.

5

Can CVE-2025-1931 be exploited remotely?

Yes, CVE-2025-1931 may potentially be exploited remotely, leading to a crash of the affected application.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203