CVE-2025-1934: Unexpected GC during RegExp bailout processing

Published Mar 4, 2025
·
Updated

It was possible to interrupt the processing of a RegExp bailout and run additional JavaScript, potentially triggering garbage collection when the engine was not expecting it. This vulnerability was fixed in Firefox 136, Firefox ESR 128.8, Thunderbird 136, and Thunderbird 128.8.

Other sources

It was possible to interrupt the processing of a RegExp bailout and run additional JavaScript, potentially triggering garbage collection when the engine was not expecting it. This vulnerability affects Firefox < 136 and Firefox ESR < 128.8.

— Red Hat

Affected Software

24 affected componentsFixes available
Mozilla Firefox<136
Mozilla Firefox ESR<128.8
Mozilla Thunderbird<136
136
Mozilla Firefox<128.8.0
Mozilla Firefox<136.0
Mozilla Thunderbird<128.8.0
Mozilla Thunderbird>=129.0<136.0
Mozilla Thunderbird<128.8
128.8
ubuntu/mozjs52*
ubuntu/mozjs38*
ubuntu/firefox<136.0+build3-0ubuntu0.20.04.1
136.0+build3-0ubuntu0.20.04.1
ubuntu/mozjs68*
ubuntu/mozjs52*
ubuntu/mozjs102*
ubuntu/mozjs78*
ubuntu/mozjs91*
ubuntu/thunderbird<1:128.12.0+build1-0ubuntu0.22.04.1
1:128.12.0+build1-0ubuntu0.22.04.1
ubuntu/mozjs102*
ubuntu/mozjs115*
Mozilla Firefox ESR<128.8
128.8
Mozilla Firefox<136
136
debian/firefox
159.0.1-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 136
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 128.8
  3. Upgrade

    Upgrade ubuntu/firefox to a version that resolves this vulnerability.

    Fixed in 136.0+build3-0ubuntu0.20.04.1
  4. Upgrade

    Upgrade ubuntu/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:128.12.0+build1-0ubuntu0.22.04.1
  5. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 136
  6. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0.1-1
  7. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  8. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
  9. Upgrade

    Upgrade Firefox to a version that resolves this vulnerability.

    Fixed in 136
  10. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 128.8
  11. Upgrade

    Upgrade Thunderbird ESR to a version that resolves this vulnerability.

    Fixed in 128.8

Event History

Mar 4, 2025
CVE Published
via Mozilla·12:00 AM
Data Sourced
via Mozilla·12:00 AM
DescriptionSeverityAffected Software
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·01:31 PM
Data Sourced
via MITRE·01:31 PM
Description
Data Sourced
via Red Hat·02:01 PM
DescriptionSeverityAffected Software
Data Sourced
via OSV·02:15 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·02:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2025-1934?

CVE-2025-1934 is considered a medium severity vulnerability due to its potential to interrupt RegExp processing and execute unintended JavaScript.

2

How do I fix CVE-2025-1934?

To fix CVE-2025-1934, update your Mozilla Firefox to version 136 or Mozilla Firefox ESR to version 128.8 or later.

3

Which versions of Firefox are affected by CVE-2025-1934?

CVE-2025-1934 affects Mozilla Firefox versions prior to 136 and Firefox ESR versions prior to 128.8.

4

Can CVE-2025-1934 allow arbitrary code execution?

Yes, CVE-2025-1934 can allow the execution of additional JavaScript, which may lead to arbitrary code execution under certain conditions.

5

What type of attack is CVE-2025-1934 associated with?

CVE-2025-1934 is associated with a potential code execution attack through RegExp bailouts in specific versions of Mozilla Firefox.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203