CVE-2018-4218: Use After Free
An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site that triggers an @generatorState use-after-free.
Other sources
WebKit. Multiple memory corruption issues were addressed with improved memory handling.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
iTunesto a version that resolves this vulnerability.Fixed in 12.7.5 - Upgrade
Upgrade
debian/webkit2gtkto a version that resolves this vulnerability.Fixed in 2.44.2-1~deb11u1Fixed in 2.50.4-1~deb11u1Fixed in 2.50.4-1~deb12u1Fixed in 2.50.4-1~deb13u1Fixed in 2.50.5-1 - Upgrade
Upgrade
Apple Safarito a version that resolves this vulnerability.Fixed in 11.1.1 - Upgrade
Upgrade
Apple iCloud for Windowsto a version that resolves this vulnerability.Fixed in 7.5 - Upgrade
Upgrade
Apple iOSto a version that resolves this vulnerability.Fixed in 11.4 - Upgrade
Upgrade
Apple iTunes for Windowsto a version that resolves this vulnerability.Fixed in 12.7.5 - Upgrade
Upgrade
Apple tvOSto a version that resolves this vulnerability.Fixed in 11.4 - Upgrade
Upgrade
Apple watchOSto a version that resolves this vulnerability.Fixed in 4.3.1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2018-4218?
The severity of CVE-2018-4218 is high, with a severity value of 8.8.
What products are affected by CVE-2018-4218?
iOS before 11.4, Safari before 11.1.1, iCloud before 7.5 on Windows, iTunes before 12.7.5 on Windows, tvOS before 11.4, and watchOS before 4.3.1 are affected by CVE-2018-4218.
How can I fix CVE-2018-4218?
Update to the latest available version of iOS, Safari, iCloud, iTunes, tvOS, and watchOS to fix CVE-2018-4218.
Are Ubuntu Linux versions affected by CVE-2018-4218?
Yes, Ubuntu Linux versions 16.04, 17.10, and 18.04 are affected by CVE-2018-4218.
Where can I find more information about CVE-2018-4218?
You can find more information about CVE-2018-4218 at the following references: [1] [2] [3]