CVE-2018-4222: Input Validation
An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code via a crafted web site that leverages a getWasmBufferFromValue out-of-bounds read during WebAssembly compilation.
Other sources
WebKit. An out-of-bounds read was addressed with improved input validation.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
iTunesto a version that resolves this vulnerability.Fixed in 12.7.5 - Upgrade
Upgrade
debian/webkit2gtkto a version that resolves this vulnerability.Fixed in 2.44.2-1~deb11u1Fixed in 2.50.4-1~deb11u1Fixed in 2.50.4-1~deb12u1Fixed in 2.50.4-1~deb13u1Fixed in 2.50.5-1 - Upgrade
Upgrade
Safarito a version that resolves this vulnerability.Fixed in 11.1.1 - Upgrade
Upgrade
iCloud for Windowsto a version that resolves this vulnerability.Fixed in 7.5 - Upgrade
Upgrade
iOSto a version that resolves this vulnerability.Fixed in 11.4 - Upgrade
Upgrade
iTunes for Windowsto a version that resolves this vulnerability.Fixed in 12.7.5 - Upgrade
Upgrade
tvOSto a version that resolves this vulnerability.Fixed in 11.4 - Upgrade
Upgrade
watchOSto a version that resolves this vulnerability.Fixed in 4.3.1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is CVE-2018-4222?
CVE-2018-4222 is a vulnerability in certain Apple products, including iOS, Safari, iCloud, iTunes, tvOS, and watchOS.
What is the severity of CVE-2018-4222?
The severity of CVE-2018-4222 is high, with a CVSS score of 8.8.
How does CVE-2018-4222 affect Apple Safari?
CVE-2018-4222 affects Safari versions before 11.1.1.
How does CVE-2018-4222 affect Apple iOS?
CVE-2018-4222 affects iOS versions before 11.4.
How can I mitigate CVE-2018-4222?
To mitigate CVE-2018-4222, update to the latest version of the affected software, such as iOS 11.4 or Safari 11.1.1.