CVE-2021-37999: Insufficient data validation in New Tab Page
Insufficient data validation in New Tab Page in Google Chrome prior to 95.0.4638.69 allowed a remote attacker to inject arbitrary scripts or HTML in a new browser tab via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 95.0.4638.69 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2021-37999?
CVE-2021-37999 is rated as high severity due to its potential to allow remote code execution in affected versions.
How do I fix CVE-2021-37999?
To mitigate CVE-2021-37999, update Google Chrome or Chromium to version 95.0.4638.69 or later.
Which versions of Google Chrome are affected by CVE-2021-37999?
CVE-2021-37999 affects Google Chrome versions prior to 95.0.4638.69.
Can CVE-2021-37999 affect Chromium installed on Debian systems?
Yes, CVE-2021-37999 affects Chromium versions up to and including 90.0.4430.212-1~deb10u1 on Debian.
What type of attack does CVE-2021-37999 enable?
CVE-2021-37999 allows remote attackers to inject arbitrary scripts or HTML code into new browser tabs.