CVE-2021-38004: Insufficient policy enforcement in Autofill
Insufficient policy enforcement in Autofill in Google Chrome prior to 95.0.4638.69 allowed a remote attacker to leak cross-origin data via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 95.0.4638.69 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2021-38004?
CVE-2021-38004 is classified as a high-severity vulnerability due to its potential for data leakage.
How do I fix CVE-2021-38004?
To fix CVE-2021-38004, update Google Chrome to version 95.0.4638.69 or later.
What software is affected by CVE-2021-38004?
CVE-2021-38004 affects Google Chrome versions prior to 95.0.4638.69 and specific versions of Chromium on Debian.
Can CVE-2021-38004 lead to data breaches?
Yes, CVE-2021-38004 can allow remote attackers to leak cross-origin data, which could potentially lead to data breaches.
How was CVE-2021-38004 discovered?
CVE-2021-38004 was discovered due to insufficient policy enforcement in the Autofill feature of Google Chrome.