CVE-2021-38001: Type Confusion in V8
Type confusion in V8 in Google Chrome prior to 95.0.4638.69 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 95.0.4638.69 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.3_git20211112-r1 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.3_git20211127-r1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2021-38001?
CVE-2021-38001 is classified as a high severity vulnerability due to its potential exploitation of heap corruption.
How do I fix CVE-2021-38001?
To mitigate CVE-2021-38001, users should upgrade to the fixed versions of Google Chrome or Chromium that are 95.0.4638.69 or later.
Who is affected by CVE-2021-38001?
CVE-2021-38001 affects multiple versions of Google Chrome and Chromium before 95.0.4638.69 and specific Debian releases.
What type of vulnerability is CVE-2021-38001?
CVE-2021-38001 is a type confusion vulnerability within the V8 engine of Google Chrome.
Could CVE-2021-38001 allow remote code execution?
Yes, if exploited, CVE-2021-38001 could allow a remote attacker to execute arbitrary code through a crafted HTML page.