CVE-2022-1097: Use After Free
<code>NSSToken</code> objects were referenced via direct points, and could have been accessed in an unsafe way on different threads, leading to a use-after-free and potentially exploitable crash. This vulnerability affects Thunderbird < 91.8, Firefox < 99, and Firefox ESR < 91.8.
Other sources
NSSToken objects were referenced via direct points, and could have been accessed in an unsafe way on different threads, leading to a use-after-free and potentially exploitable crash.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 91.8 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 99 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 91.8 - Upgrade
Upgrade
alpine/firefoxto a version that resolves this vulnerability.Fixed in 99.0-r0 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 91.8.0-r0 - Upgrade
Upgrade
alpine/librewolfto a version that resolves this vulnerability.Fixed in 99.0-r0 - Upgrade
Upgrade
alpine/nssto a version that resolves this vulnerability.Fixed in 3.68.3-r0 - Upgrade
Upgrade
alpine/nssto a version that resolves this vulnerability.Fixed in 3.72.1-r1 - Upgrade
Upgrade
alpine/nssto a version that resolves this vulnerability.Fixed in 3.76.1-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 91.8.0-r0 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 91.8.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:91.8.0-1 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is CVE-2022-1097?
CVE-2022-1097 is a vulnerability that allows for use-after-free and potentially exploitable crashes in Thunderbird and Firefox.
Which software is affected by CVE-2022-1097?
Thunderbird < 91.8, Firefox < 99, and Firefox ESR < 91.8 are affected by CVE-2022-1097.
What is the severity of CVE-2022-1097?
CVE-2022-1097 has a severity rating of 6.5 (high).
How can I fix CVE-2022-1097?
To fix CVE-2022-1097, it is recommended to update Thunderbird to version 91.8 or later, Firefox to version 99 or later, and Firefox ESR to version 91.8 or later.
Where can I find more information about CVE-2022-1097?
You can find more information about CVE-2022-1097 in the following references: [Mozilla Bugzilla](https://bugzilla.mozilla.org/show_bug.cgi?id=1745667), [Mozilla Security Advisory (mfsa2022-14)](https://www.mozilla.org/en-US/security/advisories/mfsa2022-14/), [Mozilla Security Advisory (mfsa2022-13)](https://www.mozilla.org/en-US/security/advisories/mfsa2022-13/#CVE-2022-1097).