CVE-2022-28281: High severity Mozilla Firefox ESR vulnerability
If a compromised content process sent an unexpected number of WebAuthN Extensions in a Register command to the parent process, an out of bounds write would have occurred leading to memory corruption and a potentially exploitable crash.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 91.8 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 99 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 91.8 - Upgrade
Upgrade
alpine/firefoxto a version that resolves this vulnerability.Fixed in 99.0-r0 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 91.8.0-r0 - Upgrade
Upgrade
alpine/librewolfto a version that resolves this vulnerability.Fixed in 99.0-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 91.8.0-r0 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 91.8.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:91.8.0-1 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is CVE-2022-28281?
CVE-2022-28281 is a vulnerability that can lead to memory corruption and a potentially exploitable crash in Mozilla Firefox, Firefox ESR, and Thunderbird.
What is the severity of CVE-2022-28281?
The severity of CVE-2022-28281 is high, with a severity value of 7.
How does CVE-2022-28281 occur?
CVE-2022-28281 occurs when a compromised content process sends an unexpected number of WebAuthN Extensions in a Register command to the parent process.
Which software versions are affected by CVE-2022-28281?
CVE-2022-28281 affects Mozilla Firefox ESR versions up to but excluding 91.8, Mozilla Firefox versions up to but excluding 99, and Mozilla Thunderbird versions up to but excluding 91.8.
How can I fix CVE-2022-28281?
To fix CVE-2022-28281, update your Mozilla Firefox, Firefox ESR, or Thunderbird to the latest version available from Mozilla.