CVE-2022-28282: Use After Free
By using a link with <code>rel="localization"</code> a use-after-free could have been triggered by destroying an object during JavaScript execution and then referencing the object through a freed pointer, leading to a potential exploitable crash. This vulnerability affects Thunderbird < 91.8, Firefox < 99, and Firefox ESR < 91.8.
Other sources
By using a link with rel="localization" a use-after-free could have been triggered by destroying an object during JavaScript execution and then referencing the object through a freed pointer, leading to a potential exploitable crash.
By using a link with rel="localization" a use-after-free could have been triggered by destroying an object during JavaScript execution and then referencing the object through a freed pointer, leading to a potentially exploitable crash.
— Mozilla
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 91.8 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 99 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 91.8 - Upgrade
Upgrade
alpine/firefoxto a version that resolves this vulnerability.Fixed in 99.0-r0 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 91.8.0-r0 - Upgrade
Upgrade
alpine/librewolfto a version that resolves this vulnerability.Fixed in 99.0-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 91.8.0-r0 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 91.8.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:91.8.0-1 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is CVE-2022-28282?
CVE-2022-28282 is a vulnerability that allows a use-after-free exploit by destroying an object during JavaScript execution and then referencing the object through a freed pointer, potentially leading to a crash.
Which software is affected by CVE-2022-28282?
CVE-2022-28282 affects Thunderbird < 91.8 and Firefox ESR < 91.8.
What is the severity of CVE-2022-28282?
CVE-2022-28282 has a severity rating of 6.5, which is classified as medium.
How can I fix CVE-2022-28282?
To fix CVE-2022-28282, update your Thunderbird to version 91.8 or higher, or update your Firefox ESR to version 91.8 or higher.
Where can I find more information about CVE-2022-28282?
You can find more information about CVE-2022-28282 on the Mozilla Bugzilla and Mozilla security advisories websites.