CVE-2024-11695: Medium severity Mozilla Thunderbird vulnerability

Published Nov 26, 2024
·
Updated

A crafted URL containing Arabic script and whitespace characters could have hidden the true origin of the page, resulting in a potential spoofing attack.

Affected Software

21 affected componentsFixes available
Mozilla Thunderbird<133
133
Mozilla Thunderbird<128.5
128.5
Mozilla Firefox<133
133
Mozilla Firefox ESR<128.5
128.5
Mozilla Firefox<128.5.0
Mozilla Firefox<133.0
Mozilla Thunderbird<128.5.0
Mozilla Thunderbird>=129.0<133.0
debian/firefox-esr<128.5.0esr-1~deb12u1
128.5.0esr-1~deb12u1
debian/firefox-esr<128.5.0esr-1
128.5.0esr-1
debian/firefox-esr<128.5.0esr-1
128.5.0esr-1
debian/thunderbird<1:128.5.0esr-1~deb12u1
1:128.5.0esr-1~deb12u1
debian/thunderbird<1:128.5.0esr-1
1:128.5.0esr-1
debian/thunderbird<1:128.5.0esr-1
1:128.5.0esr-1
debian/firefox
159.0-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1
alpine/thunderbird>=129.0<128.5.0-r0
128.5.0-r0
alpine/thunderbird>=129.0<128.5.0-r0
128.5.0-r0
alpine/thunderbird>=129.0<128.5.0-r0
128.5.0-r0
alpine/thunderbird>=129.0<128.5.0-r0
128.5.0-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 133
  2. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 128.5
  3. Upgrade

    Upgrade Firefox to a version that resolves this vulnerability.

    Fixed in 133
  4. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 128.5
  5. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 128.5.0esr-1~deb12u1
  6. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 128.5.0esr-1
  7. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:128.5.0esr-1~deb12u1
  8. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:128.5.0esr-1
  9. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0-1
  10. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  11. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
  12. Upgrade

    Upgrade alpine/thunderbird to a version that resolves this vulnerability.

    Fixed in 128.5.0-r0
  13. Upgrade

    Upgrade Thunderbird ESR to a version that resolves this vulnerability.

    Fixed in 128.5

Event History

Nov 26, 2024
CVE Published
via Mozilla·12:00 AM
CVE Published
via MITRE·01:33 PM
Data Sourced
via MITRE·01:33 PM
DescriptionWeakness
Data Sourced
via Red Hat·02:03 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·02:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·02:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2024-11695?

CVE-2024-11695 has a severity rating indicating it can lead to potential spoofing attacks.

2

How do I fix CVE-2024-11695?

To mitigate CVE-2024-11695, update your browser to Firefox and Thunderbird versions above 133 or the specific Debian package updates listed.

3

Which software is affected by CVE-2024-11695?

CVE-2024-11695 affects Mozilla Firefox, Mozilla Thunderbird, and Firefox ESR versions below 134 and 128.6.0esr-1.

4

What type of vulnerability is CVE-2024-11695?

CVE-2024-11695 is a spoofing vulnerability caused by crafted URLs containing Arabic scripts and whitespace characters.

5

What are the potential impacts of CVE-2024-11695?

The potential impacts of CVE-2024-11695 include the risk of users being misled by deceptive URLs, compromising their security.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203