CVE-2024-11704: Double Free
A double-free issue could have occurred in secpkcs7decoderstartdecrypt() when handling an error path. Under specific conditions, the same symmetric key could have been freed twice, potentially leading to memory corruption. This vulnerability affects Firefox < 133, Thunderbird < 133, Firefox ESR < 128.7, and Thunderbird < 128.7.
Other sources
A double-free issue could have occurred in secpkcs7decoderstartdecrypt() when handling an error path. Under specific conditions, the same symmetric key could have been freed twice, potentially leading to memory corruption.
— Mozilla
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 133 - Upgrade
Upgrade
Firefoxto a version that resolves this vulnerability.Fixed in 133 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 128.7 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 128.7 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 128.7.0esr-1~deb12u1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 128.7.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:128.7.0esr-1~deb12u1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:128.7.0esr-1 - Upgrade
Upgrade
Thunderbird ESRto a version that resolves this vulnerability.Fixed in 128.7
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
- CVE-2024-11691
- CVE-2024-11700
- CVE-2024-11692
- CVE-2024-11701
- CVE-2024-11702
- CVE-2024-11693
- CVE-2024-11694
- CVE-2024-11695
- CVE-2024-11696
- CVE-2024-11697
- CVE-2024-11704
- CVE-2024-11698
- CVE-2024-11705
- CVE-2024-11706
- CVE-2024-11708
- CVE-2024-11699
- CVE-2024-11703
- CVE-2025-1009
- CVE-2025-1010
- CVE-2025-1011
- CVE-2025-1012
- CVE-2025-1013
- CVE-2025-1014
- CVE-2025-1016
- CVE-2025-1017
- CVE-2025-1015
- CVE-2025-0510
- DLA-4044-1
- DLA-4045-1
Frequently Asked Questions
What is the severity of CVE-2024-11704?
CVE-2024-11704 is classified as a medium severity vulnerability due to its potential for memory corruption.
How do I fix CVE-2024-11704?
To address CVE-2024-11704, update your Mozilla Thunderbird or Firefox to version 133 or later.
What vulnerabilities does CVE-2024-11704 affect?
CVE-2024-11704 affects Mozilla Firefox versions prior to 133 and Mozilla Thunderbird versions prior to 133.
What are the consequences of CVE-2024-11704?
The double-free issue in CVE-2024-11704 could lead to memory corruption, potentially impacting application stability.
Is CVE-2024-11704 present in Firefox ESR and Thunderbird?
Yes, CVE-2024-11704 impacts Firefox ESR versions up to 128.7 and Thunderbird versions up to 128.7.