CVE-2025-1011: A bug in WebAssembly code generation could result in a crash

Published Feb 4, 2025
·
Updated

A bug in WebAssembly code generation could have lead to a crash. It may have been possible for an attacker to leverage this to achieve code execution. This vulnerability was fixed in Firefox 135, Firefox ESR 128.7, Thunderbird 128.7, and Thunderbird 135.

Other sources

A bug in WebAssembly code generation could have lead to a crash. It may have been possible for an attacker to leverage this to achieve code execution. This vulnerability affects Firefox < 135, Firefox ESR < 128.7, Thunderbird < 128.7, and Thunderbird < 135.

— Red Hat

Affected Software

22 affected componentsFixes available
Mozilla Firefox<135
135
Mozilla Firefox ESR<128.7
128.7
Mozilla Thunderbird<135
135
Mozilla Firefox<128.7.0
Mozilla Firefox<135.0
Mozilla Thunderbird<135.0
Mozilla Thunderbird>=128.0.1<128.7.0
ubuntu/mozjs52*
ubuntu/mozjs38*
ubuntu/firefox<135.0+build2-0ubuntu0.20.04.1
135.0+build2-0ubuntu0.20.04.1
ubuntu/mozjs68*
ubuntu/mozjs52*
ubuntu/mozjs102*
ubuntu/mozjs78*
ubuntu/mozjs91*
ubuntu/thunderbird<1:128.12.0+build1-0ubuntu0.22.04.1
1:128.12.0+build1-0ubuntu0.22.04.1
ubuntu/mozjs102*
ubuntu/mozjs115*
Mozilla Thunderbird<128.7
128.7
debian/firefox
159.0-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u11:140.12.0esr-1~deb13u11:153.5.1esr-1~deb13u21:153.5.0esr-11:153.6.0esr-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Firefox to a version that resolves this vulnerability.

    Fixed in 135
  2. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 128.7
  3. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 135
  4. Upgrade

    Upgrade ubuntu/firefox to a version that resolves this vulnerability.

    Fixed in 135.0+build2-0ubuntu0.20.04.1
  5. Upgrade

    Upgrade ubuntu/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:128.12.0+build1-0ubuntu0.22.04.1
  6. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 128.7
  7. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0-1
  8. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  9. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u1Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.5.1esr-1~deb13u2Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
  10. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 128.7

Event History

Feb 4, 2025
CVE Published
via Mozilla·12:00 AM
Data Sourced
via Mozilla·12:00 AM
DescriptionSeverityAffected Software
CVE Published
via MITRE·01:58 PM
Data Sourced
via MITRE·01:58 PM
Description
Data Sourced
via NVD·02:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Red Hat·03:01 PM
DescriptionSeverityAffected Software
Feb 6, 2025
Data Sourced
via OSV·12:00 AM
DescriptionSeverityAffected Software
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2025-1011?

CVE-2025-1011 has a high severity rating due to its potential for code execution via a bug in WebAssembly.

2

How do I fix CVE-2025-1011?

To fix CVE-2025-1011, update Mozilla Thunderbird or Firefox to versions above 128.7 or 135, as applicable.

3

What software is affected by CVE-2025-1011?

CVE-2025-1011 affects Mozilla Thunderbird, Firefox, and Firefox ESR versions up to 128.7 and 135.

4

Can CVE-2025-1011 cause system crashes?

Yes, CVE-2025-1011 can lead to crashes due to a bug in WebAssembly code generation.

5

Is it possible to exploit CVE-2025-1011 remotely?

Yes, an attacker may be able to exploit CVE-2025-1011 remotely to achieve code execution.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203